<!DOCTYPE html>
<html><head><meta charset="utf-8"><meta content="width=device-width, initial-scale=1.0, maximum-scale=1.0, user-scalable=no" name="viewport"><meta content="noodp" name="robots"><script src="/cdn-cgi/apps/head/CPAvilUg4YMJGMgeLVg6ViV-Q9o.js"></script><link href="/rss/frontpage.xml" rel="alternate" title="Latest Articles" type="application/rss+xml"><link href="/rss/news.xml" rel="alternate" title="Front Page News" type="application/rss+xml"><meta content="summary" name="twitter:card"><meta content="http://www.somethingawful.com/a/14939/" name="twitter:url"><meta content="You Might Be a Redneck Jokes From &quot;The Road&quot;" name="twitter:title"><meta content="Jeff Foxworthy&#39;s humor endures the waning light of civilization on The Road." name="twitter:description"><meta content="http://i.somethingawful.com/sasbi/promo/435ad9b3/729fb0ca/87e1aeca/02f48b5b/14939newsimg.jpg" name="twitter:image"><meta content="@somethingawful" name="twitter:site"><meta content="@sexyfacts4u" name="twitter:creator"><meta content="article" property="og:type"><meta content="Something Awful - You Might Be a Redneck Jokes From &quot;The Road&quot;" property="og:title"><meta content="http://www.somethingawful.com/news/cormac-foxworthy-road/" property="og:url"><meta content="http://i.somethingawful.com/sasbi/promo/435ad9b3/729fb0ca/87e1aeca/02f48b5b/14939newsimg.jpg" property="og:image"><meta content="somethingawful.com" property="og:site_name"><meta content="Jeff Foxworthy&#39;s humor endures the waning light of civilization on The Road." property="og:description"><meta content="2017-12-29T06:55:30+00:00" property="og:updated_time"><title>You Might Be a Redneck Jokes From &quot;The Road&quot;</title><link href="//static.somethingawful.com/css/main.css" rel="stylesheet" type="text/css"><!--[if lt IE 8]><link rel="stylesheet" type="text/css" href="//static.somethingawful.com/css/ie.css"><![endif]--><script src="//ajax.googleapis.com/ajax/libs/jquery/2.2.2/jquery.min.js" type="text/javascript"><script type="text/javascript" src="https://cdnjs.cloudflare.com/ajax/libs/jquery-migrate/1.4.0/jquery-migrate.min.js"></script></script><script src="//static.somethingawful.com/js/site.min.js" type="text/javascript"></script><script id="twitter-wjs" src="//platform.twitter.com/widgets.js" type="text/javascript"></script><script id="facebook-jssdk" src="//connect.facebook.net/en_US/all.js#xfbml=1" type="text/javascript"></script><script src="//static.somethingawful.com/js/jwplayer/jwplayer.js" type="text/javascript"></script><script src="//static.somethingawful.com/js/article.min.js" type="text/javascript"></script></head><body class="sa article c_63 a_14939"><script type="text/javascript">var _gaq = _gaq || [];_gaq.push(['_setAccount', 'UA-33089744-1']);_gaq.push(['_trackPageview']);(function() {var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);})();</script><div class="chuck"><div class="neck"><ul class="scalp"><li><a href="/">Something Awful</a></li><li><a href="http://forums.somethingawful.com/">Something Awful Forums</a></li></ul><div class="head"><a class="logo" href="/"><span>Something Awful</span></a> <iframe class="ad" data-unit="top" src="about:blank"></iframe></div></div></div><div class="sirloin"><div class="ribs"><div class="site-nav"><ul><li class="forums"><a href="http://forums.somethingawful.com/">Forums</a></li><li class="photoshop-phriday"><a href="/photoshop-phriday/"><span class="full">Photoshop Phriday</span><span class="short">Photoshop</span></a></li><li class="comedy-goldmine"><a href="/comedy-goldmine/"><span class="full">Comedy Goldmine</span><span class="short">Goldmine</span></a></li><li class="the-flash-tub"><a href="/flash-tub/"><span class="full">The Flash Tub</span><span class="short">Flash Tub</span></a></li><li class="wtf-dd"><a href="/dungeons-and-dragons/"><span class="full">WTF, D&amp;D?!?</span><span class="short">WTFDD</span></a></li><li class="front-page-articles"><a href="/news/"><span class="full">Front Page Articles</span><span class="short">Front Page</span></a></li><li class="the-everdraed-showcase"><a href="/everdraed-showcase/"><span class="full">The Everdraed Showcase</span><span class="short">Everdraed</span></a></li><li class="video-game-article"><a href="/video-game-article/"><span class="full">Video Game Article</span><span class="short">Video Game</span></a></li><li class="current-releases"><a href="/current-movie-reviews/">Current Releases</a></li><li class="directory"><div class="directory-button"><a href="/directory/">Directory</a><div class="directory"><div class="item"><h4>Media</h4><ul><li><a href="/d/photoshop-phriday/">Photoshop Phriday</a></li><li><a href="/d/flash-tub/">The Flash Tub</a></li><li><a href="/d/comedy-goldmine/">Comedy Goldmine</a></li><li><a href="http://www.centralarc.com">Central ARC</a></li><li><a href="http://www.awfulvideo.com">Awful Video</a></li><li><a href="/d/cliff-yablonski/">Cliff Yablonski</a></li><li><a href="/booklist/index.htm">My Tank is Fight</a></li><li><a href="/d/directory.php#media">More</a></li></ul></div><div class="item"><h4>Articles</h4><ul><li><a href="/d/awful-movie-database/">Awful Movie Database</a></li><li><a href="/d/second-life-safari/">Secondlife Safari</a></li><li><a href="/d/weekend-web/">Weekend Web</a></li><li><a href="/d/pregame-wrapup/">Pregame Wrapup</a></li><li><a href="/d/icq-pranks/">Pranks (ICQ)</a></li><li><a href="/d/email-pranks/">Pranks (E-mail)</a></li><li><a href="/d/video-game-article/">Video Game Article</a></li><li><a href="/d/directory.php#articles">More</a></li></ul></div><div class="item"><h4>Reviews</h4><ul><li><a href="/d/your-band-sucks/">Your Band Sucks</a></li><li><a href="/d/movie-reviews/">Movie Reviews</a></li><li><a href="/d/hentai-game-reviews/">Awful Anime</a></li><li><a href="/d/rom-pit/">ROM Pit</a></li><li><a href="/d/fashion-swat/">Fashion SWAT</a></li><li><a href="/d/guides/">Guides</a></li><li><a href="/d/game-reviews/">Game Reviews</a></li><li><a href="/d/directory.php#reviews">More</a></li></ul></div><div class="item"><h4>Hosted</h4><ul><li><a href="/hosted/86">#86/68</a></li><li><a href="/hosted/adventures">Daring Armstrong</a></li><li><a href="/hosted/automaticturban">Semi-Automatic Turban</a></li><li><a href="/hosted/cliff">Cliff Yablonski</a></li><li><a href="/hosted/crabs">Leonard Crabs</a></li><li><a href="/hosted/cranky">Cranky Steve</a></li><li><a href="/hosted/drdraw">Dr Draw</a></li><li><a href="/hosted/edbaker">Ed Baker</a></li><li><a href="/hosted/firemancomics">Fireman Comics</a></li><li><a href="/hosted/jeffk">JEFF K</a></li></ul></div><div class="item"><h4>Forums</h4><ul><li><a href="http://forums.somethingawful.com/forumdisplay.php?forumid=1">General Discussion</a></li><li><a href="http://forums.somethingawful.com/forumdisplay.php?forumid=44">Video Games</a></li><li><a href="http://forums.somethingawful.com/forumdisplay.php?forumid=22">Hardware &amp; Software</a></li><li><a href="http://forums.somethingawful.com/forumdisplay.php?forumid=122">Sports</a></li><li><a href="http://forums.somethingawful.com/forumdisplay.php?forumid=133">Movie Reviews</a></li><li><a href="http://forums.somethingawful.com/forumdisplay.php?forumid=150">Music</a></li><li><a href="http://forums.somethingawful.com/forumdisplay.php?forumid=130">TV</a></li><li><a href="http://forums.somethingawful.com/">More</a></li></ul></div></div></div></li></ul></div><div class="brisket"><div class="cavity full top"><div class="organ breadcrumbs"> <a href="/directory/#articles">Articles</a> &gt; <a href="/news/">Front Page News</a></div></div><div class="cavity left"><div class="organ article_meta"><div class="article_head"><h1><a href="/news/cormac-foxworthy-road/">You Might Be a Redneck Jokes From &quot;The Road&quot;</a></h1> <span class="date">Friday, Dec 29, 2017</span> by <span class="authors"><span class="author"><a href="/author/12/">Zack &#34;Geist Editor&#34; Parsons</a> (<a href="http://twitter.com/sexyfacts4u" target="_blank">@sexyfacts4u</a>)</span></span> </div><div class="social"><div class="twitter_tweet"><a class="twitter-share-button" data-counturl="http://www.somethingawful.com/news/cormac-foxworthy-road/" data-hashtags="somethingawful" data-related="sexyfacts4u" data-text="You Might Be a Redneck Jokes From &quot;The Road&quot;" data-url="http://www.somethingawful.com/news/cormac-foxworthy-road/" data-via="somethingawful" href="https://twitter.com/share"></a></div><div class="facebook_like"><div class="fb-like" data-font="arial" data-href="http://www.somethingawful.com/news/cormac-foxworthy-road/" data-layout="button_count" data-send="false" data-show-faces="false" data-width="100"></div></div></div></div><div class="organ article"><p><img alt="" class="imgcap" src="http://i.somethingawful.com/u/elpintogrande/112017/theroad.jpg" width="635" /><br /> <span class="font_big"><br /> If every moment the world dims darker than the last and you're still hunting for a Coors and a camouflage koozie... you might be a redneck.</span><br /> <span class="font_big"><br /> If you travel through a dying world maintaining the fire even in the dark in order to find more dip... you might be a redneck.<br /> </span><br /> <span class="font_big">If the only thing keepin' you from cannibalism is the idea of having to run to catch somebody... you might be a redneck.<br /> </span><br /> <span class="font_big">If your breath is the breath of god passed from man to man through all of time but you prefer to breathe a BBQ vape... you might be a redneck.</span><br /></p><p><span class="font_big">If y'all are standing at a crossroads of a ground set with dolmen stones where the spoken bones of oracles lay moldering and you start thinkin' about a rerun of Pawn Stars... you might just be a redneck.</span><br /></p><p><span class="font_big">If your first reaction to somebody trying to cannibalize you is to tell them to start with your butt so they can kiss your dang ass... you might be a redneck.</span><br /></p><p><span class="font_big">If y'all come upon the blackened skeleton of a monster truck risin' up like the bones of a mammoth from the clotted brackland and you get so excited you shoot off your suicide bullet in celebration... y'all might just be a redneck.</span><br /></p><p><span class="font_big">If you're just trying to be the last man alive so you can have all the WWE title belts to yourself... you might be a redneck.</span><br /></p><p><span class="font_big">If you're still scribblin' down ideas for tattoos even though you ate the last tattoo artist... you might be a redneck.</span><br /></p><p><span class="font_big">If you find the crozzled wreck of a car and you go huntin' in the rubble for cinderblocks to put under it... you might be a redneck.</span><br /></p><p><span class="font_big">When you sometimes thing about how bein' a truck driver is no different from bein' a wizard in that they are both impossible so you figure on just calling yourself a wizard from that point forward... you might be a redneck.</span><br /></p><p><span class="font_big">If once there were brook trout in the streams in the mountains. You could see them standing in the amber current where the white edges of their fins wimpled softly in the flow. They smelled of moss in your hand. Polished and muscular and torsional. On their backs were vermiculate patterns that were maps of the world in its becoming. Maps and mazes. Of a thing which could not be put back. Not be made right again. In the deep glens where they lived all things were older than man and they hummed of mystery. And that was why those places were dang perfect for muddin'... you might be a redneck.</span></p><div class="pb"></div><p class="signoff">–&nbsp;<span class="author"><a href="/author/12/">Zack &#34;Geist Editor&#34; Parsons</a> (<a href="http://twitter.com/sexyfacts4u" target="_blank">@sexyfacts4u</a>)</span></p></div><div class="organ article_nav"> <a class="previous" href="/news/get-a-girlfriend/" title="The Top 5 Guaranteed Ways To Get a Girlfriend in 2018!">Previous</a> <a class="more" href="/news/">More Front Page News</a> </div><div class="organ recent_articles"><h4>This Week on Something Awful...</h4><ul class="news"><li><div class="a_info"> <a class="image normal" href="/news/cormac-foxworthy-road/"> <img alt="You Might Be a Redneck Jokes From &amp;quot;The Road&amp;quot;" class="normal" src="http://i.somethingawful.com/sasbi/promo/435ad9b3/729fb0ca/87e1aeca/02f48b5b/14939.jpg"> </a> <div class="info"><h3><a href="/news/cormac-foxworthy-road/">You Might Be a Redneck Jokes From &quot;The Road&quot;</a> </h3><div class="byline"><span class="date">12-29-2017</span> by <span class="authors"><span class="author"><a href="/author/12/">Zack &#34;Geist Editor&#34; Parsons</a></span></span> </div><p>Jeff Foxworthy&#39;s humor endures the waning light of civilization on The Road.</p></div><div class="pb"></div></div></li><li><div class="a_info"> <a class="image normal" href="/news/get-a-girlfriend/"> <img alt="The Top 5 Guaranteed Ways To Get a Girlfriend in 2018!" class="normal" src="http://i.somethingawful.com/sasbi/promo/a9fd61fc/1d487cfa/cd6260db/596096c9/14938.jpg"> </a> <div class="info"><h3><a href="/news/get-a-girlfriend/">The Top 5 Guaranteed Ways To Get a Girlfriend in 2018!</a> </h3><div class="byline"><span class="date">12-28-2017</span> by <span class="authors"><span class="author"><a href="/author/3/">Rich &#34;Lowtax&#34; Kyanka</a></span></span> </div><p>Everybody loves lists! Everybody loves articles about how to get a girlfriend and do the dirty things with her! Everybody loves articles about the upcoming new year!</p></div><div class="pb"></div></div></li></ul><ul class="featured"><li><div class="a_info"> <a class="image small" href="/video-game-article/elba-top-games/"> <img alt="Special Guest Idris Elba&#39;s (Not a Joke) Top 10 Games of 2017" class="small" src="http://i.somethingawful.com/sasbi/promo/5e2020a9/be8dde3f/d1fdd77c/4d3b9762/14935t.jpg"> </a> <div class="info"><h3><a href="/video-game-article/elba-top-games/">Special Guest Idris Elba's (Not a Joke) Top 10 Games of 2017</a> </h3><div class="c_name"> <a href="/video-game-article/">Video Game Article</a> </div><p>We&#39;d like to thank Mr. Elba for taking the time to make this possible.</p></div><div class="pb"></div></div></li><li><div class="a_info"> <a class="image small" href="/video-game-article/pubg-lady-parts/"> <img alt="Patch Notes: The PUBG Girl Parts Update" class="small" src="http://i.somethingawful.com/sasbi/promo/490efb66/c5016fa8/8d6fcbc4/e505a7ef/14926t.jpg"> </a> <div class="info"><h3><a href="/video-game-article/pubg-lady-parts/">Patch Notes: The PUBG Girl Parts Update</a> </h3><div class="c_name"> <a href="/video-game-article/">Video Game Article</a> </div><p>23 million copies sold, 1 human anatomy book purchased</p></div><div class="pb"></div></div></li><li><div class="a_info"> <a class="image small" href="/video-game-article/game-year-award/"> <img alt="2017 Game of the Year Awards Part One: January to July" class="small" src="http://i.somethingawful.com/sasbi/promo/d4aac89c/f9a63cc7/ee532872/5120289b/14920t.png"> </a> <div class="info"><h3><a href="/video-game-article/game-year-award/">2017 Game of the Year Awards Part One: January to July</a> </h3><div class="c_name"> <a href="/video-game-article/">Video Game Article</a> </div><p>For fans of meaningless awards, these awards are extra meaningless.</p></div><div class="pb"></div></div></li></ul></div><div class="pb"></div></div><div class="cavity right"><div class="organ adrect"><iframe class="ad" data-unit="right" src="about:blank"></iframe></div><div class="organ "><h3>About This Column</h3><div class="lining"><p>The Something Awful front page news tackles anything both off and on the Internet. Mostly "on" though, as we're all incredible nerds.</p><h4>Previous Articles</h4><ul class="previous_articles"><li><a href="/news/get-a-girlfriend/">The Top 5 Guaranteed Ways To Get a Girlfriend in 2018!</a></li><li><a href="/news/after-christmas-shopping/">Your Three Days After Christmas Shopping Guide</a></li><li><a href="/news/mike-cernovich-award/">FOR RELEASE: Cernovich Recieves Incredible Award for Heroic Deeds</a></li><li><a href="/news/magic-leap-prototype/">The Complete History of Magic Leap Prototypes: Leap Before You Look</a></li><li><a href="/news/levi-wyatt-koch/">Me and Wyatt Koch Gave Sherm to Track Palin</a></li></ul><div class="more"><a href="/news/">More</a></div><h4>Suggested Articles</h4><ul class="suggested_articles"><li><a href="/news/redneck-rapture-tribulation/">You Might Be a Redneck Jokes Following the Rapture</a></li><li><a href="/news/jeff-foxworthy-singularity/">You Might Be a Redneck Jokes During the Technological Singularity</a></li><li><a href="/news/foxworthy-mirror-universe/">You Might Be a Redneck Jokes From a Sinister Mirror Universe</a></li><li><a href="/levi-johnston/levi-weird-twitter/">I AM MONETIZING MY WEIRD TWEETS</a></li><li><a href="/awful-links/shadow-vampuss/">Vampuss (Thanks, hello binga!)</a></li></ul></div></div><div class="organ whatshot"><h3>What&#39;s Hot</h3><div class="lining"><ul class="whatshot"><li><a href="/dungeons-and-dragons/wtf-dnd-modron/1/">Advanced Dungeons &amp; Dragons: Monster Manual II (part 1)</a></li><li><a href="/news/rnc-celebrity-guests/">Celebrity Speakers Cut from the 2016 Republican National Convention</a></li><li><a href="/news/pokemon-go-letter/">WHAT TO DO RE: THOSE MISERABLE FUCKS IN TEAM MYSTIC</a></li><li><a href="/feature-articles/make-someone-cry/">How To Make Someone Cry</a></li><li><a href="/video-game-article/pubg-lady-parts/">Patch Notes: The PUBG Girl Parts Update</a></li></ul></div></div><div class="organ popular_threads"><h3>Popular Threads</h3><div class="lining"><ul class="random"><li><img alt="" height="15" src="https://fi.somethingawful.com/images/shitpost.gif" width="60"> <a href="http://forums.somethingawful.com/showthread.php?threadid=3844896" title="If you want to play Pokemon at work">If you want to play Pokemon at work</a></li><li><img alt="" height="15" src="https://fi.somethingawful.com/forums/posticons/cd_action.gif" width="60"> <a href="http://forums.somethingawful.com/showthread.php?threadid=3844897" title="What are your NYE plans GBS">What are your NYE plans GBS</a></li><li><img alt="" height="15" src="https://fi.somethingawful.com/forums/posticons/byob-shocking.gif" width="60"> <a href="http://forums.somethingawful.com/showthread.php?threadid=3844889" title="I, too, am an adult without accomplishments">I, too, am an adult without accomplishments</a></li><li><img alt="" height="15" src="https://fi.somethingawful.com/forums/posticons/icons-08/politics.png" width="60"> <a href="http://forums.somethingawful.com/showthread.php?threadid=3844875" title="ITT we are Alex Jones, but from a game/movie universe">ITT we are Alex Jones, but from a game/movie universe</a></li><li><img alt="" height="15" src="https://fi.somethingawful.com/forums/posticons/icons-08/gross.png" width="60"> <a href="http://forums.somethingawful.com/showthread.php?threadid=3844892" title="im watching to catch a predator on youtube">im watching to catch a predator on youtube</a></li><li><img alt="" height="15" src="https://fi.somethingawful.com/forums/posticons/lan-asia.gif" width="60"> <a href="http://forums.somethingawful.com/showthread.php?threadid=3844903" title="Looking for some anime to watch">Looking for some anime to watch</a></li><li><img alt="" height="15" src="https://fi.somethingawful.com/forums/posticons/icons-08/games.png" width="60"> <a href="http://forums.somethingawful.com/showthread.php?threadid=3844911" title="The greatest boss battle of all time.">The greatest boss battle of all time.</a></li><li><img alt="" height="15" src="https://fi.somethingawful.com/forums/posticons/RP-seriea.gif" width="60"> <a href="http://forums.somethingawful.com/showthread.php?threadid=3844858" title="Milan legend George Weah elected as president of Liberia">Milan legend George Weah elected as president of Liberia</a></li></ul></div></div><div class="organ random_articles"><h3>Random Articles</h3><div class="lining"><ul class="random"><li><a href="/movie-reviews/post-impact-cain/">Post Impact</a></li><li><a href="/comedy-goldmine/mspaint-your-pet/1/">MSPaint your pet peeves about college</a></li><li><a href="/photoshop-phriday/draw-defective-pokemon2/1/">Let's Draw Defective Pokemon! (Part 2 of 2)</a></li><li><a href="/news/google-future-fat/">Google Future - The World is Fat</a></li><li><a href="/awful-links/vampire-huntress-sword/">Vampire Huntress</a></li></ul><div class="more"><a href="/random/" rel="nofollow">Random!</a></div></div></div><div class="organ side_search"><h3>Search</h3><div class="lining"><form action="/search/" class="site" method="get"><div class="iwrapper"><input name="q" placeholder="Search SA" type="text" /></div><button class="ui small">GO</button> <input name="t" type="hidden" value="0" /> <input name="c" type="hidden" value="0" /> <input name="a" type="hidden" value="0" /> <input name="y" type="hidden" value="0" /> <input name="p" type="hidden" value="1" /></form><form action="/search/amazon/" class="amazon" method="post" target="_blank"><div class="iwrapper"><input name="q" placeholder="Search Amazon" type="text" /></div><button class="ui small">GO</button></form><div class="links"><a class="email" href="mailto:webmaster@somethingawful.com">Email Rich "Lowtax" Kyanka</a> <a class="advertise" href="/feature-articles/something-awful-advertising/">Advertise on SA</a></div></div></div><div class="pb"></div></div><div class="cavity full bottom"><div class="organ ad leaderboard"><iframe class="ad" data-unit="bottom" src="about:blank"></iframe></div></div></div></div></div><div class="rump"><div class="leg"><div class="hoof"><p><strong>Copyright ©2017</strong> Rich "Lowtax" Kyanka &amp; Something Awful LLC.</p><ul><li><a href="mailto:lowtax@somethingawful.com">Email Rich "Lowtax" Kyanka</a></li><li><a href="mailto:advertising@somethingawful.com">Advertise on this site</a></li><li><a href="/feature-articles/website-privacy-policy/">Privacy Statement</a></li><li><a href="/alod/new/">Submit Awful Link</a></li></ul></div></div></div></body></html>