<!DOCTYPE html>
<html><head><meta charset="utf-8"><meta content="width=device-width, initial-scale=1.0, maximum-scale=1.0, user-scalable=no" name="viewport"><meta content="noodp" name="robots"><script src="/cdn-cgi/apps/head/wGdveruCsDq4Rc2yjSiIHhC2imI.js"></script><link href="/rss/frontpage.xml" rel="alternate" title="Latest Articles" type="application/rss+xml"><link href="/rss/news.xml" rel="alternate" title="Front Page News" type="application/rss+xml"><meta content="summary" name="twitter:card"><meta content="http://www.somethingawful.com/a/14821/" name="twitter:url"><meta content="Watch Me Fix The 'Assassin In Love' Movie Poster" name="twitter:title"><meta content="Honestly, the Assassin In Love poster is nearly perfect to begin with. It just needs a few minor tweaks." name="twitter:description"><meta content="http://i.somethingawful.com/sasbi/promo/00b5d269/2a781b6a/9d3d1522/c6e9d1ad/14821newsimg.jpg" name="twitter:image"><meta content="@somethingawful" name="twitter:site"><meta content="@DennisFarrell" name="twitter:creator"><meta content="article" property="og:type"><meta content="Something Awful - Watch Me Fix The 'Assassin In Love' Movie Poster" property="og:title"><meta content="http://www.somethingawful.com/news/assassin-love-poster/" property="og:url"><meta content="http://i.somethingawful.com/sasbi/promo/00b5d269/2a781b6a/9d3d1522/c6e9d1ad/14821newsimg.jpg" property="og:image"><meta content="somethingawful.com" property="og:site_name"><meta content="Honestly, the Assassin In Love poster is nearly perfect to begin with. It just needs a few minor tweaks." property="og:description"><meta content="2017-07-25T00:00:00+00:00" property="og:updated_time"><title>Watch Me Fix The 'Assassin In Love' Movie Poster</title><link href="//static.somethingawful.com/css/main.css" rel="stylesheet" type="text/css"><!--[if lt IE 8]><link rel="stylesheet" type="text/css" href="//static.somethingawful.com/css/ie.css"><![endif]--><script src="//ajax.googleapis.com/ajax/libs/jquery/2.2.2/jquery.min.js" type="text/javascript"><script type="text/javascript" src="https://cdnjs.cloudflare.com/ajax/libs/jquery-migrate/1.4.0/jquery-migrate.min.js"></script></script><script src="//static.somethingawful.com/js/site.min.js" type="text/javascript"></script><script id="twitter-wjs" src="//platform.twitter.com/widgets.js" type="text/javascript"></script><script id="facebook-jssdk" src="//connect.facebook.net/en_US/all.js#xfbml=1" type="text/javascript"></script><script src="//static.somethingawful.com/js/jwplayer/jwplayer.js" type="text/javascript"></script><script src="//static.somethingawful.com/js/article.min.js" type="text/javascript"></script></head><body class="sa article c_63 a_14821"><script type="text/javascript">var _gaq = _gaq || [];_gaq.push(['_setAccount', 'UA-33089744-1']);_gaq.push(['_trackPageview']);(function() {var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);})();</script><div class="chuck"><div class="neck"><ul class="scalp"><li><a href="/">Something Awful</a></li><li><a href="http://forums.somethingawful.com/">Something Awful Forums</a></li></ul><div class="head"><a class="logo" href="/"><span>Something Awful</span></a> <iframe class="ad" data-unit="top" src="about:blank"></iframe></div></div></div><div class="sirloin"><div class="ribs"><div class="site-nav"><ul><li class="forums"><a href="http://forums.somethingawful.com/">Forums</a></li><li class="photoshop-phriday"><a href="/photoshop-phriday/"><span class="full">Photoshop Phriday</span><span class="short">Photoshop</span></a></li><li class="comedy-goldmine"><a href="/comedy-goldmine/"><span class="full">Comedy Goldmine</span><span class="short">Goldmine</span></a></li><li class="the-flash-tub"><a href="/flash-tub/"><span class="full">The Flash Tub</span><span class="short">Flash Tub</span></a></li><li class="wtf-dd"><a href="/dungeons-and-dragons/"><span class="full">WTF, D&amp;D?!?</span><span class="short">WTFDD</span></a></li><li class="front-page-articles"><a href="/news/"><span class="full">Front Page Articles</span><span class="short">Front Page</span></a></li><li class="the-everdraed-showcase"><a href="/everdraed-showcase/"><span class="full">The Everdraed Showcase</span><span class="short">Everdraed</span></a></li><li class="video-game-article"><a href="/video-game-article/"><span class="full">Video Game Article</span><span class="short">Video Game</span></a></li><li class="current-releases"><a href="/current-movie-reviews/">Current Releases</a></li><li class="directory"><div class="directory-button"><a href="/directory/">Directory</a><div class="directory"><div class="item"><h4>Media</h4><ul><li><a href="/d/photoshop-phriday/">Photoshop Phriday</a></li><li><a href="/d/flash-tub/">The Flash Tub</a></li><li><a href="/d/comedy-goldmine/">Comedy Goldmine</a></li><li><a href="http://www.centralarc.com">Central ARC</a></li><li><a href="http://www.awfulvideo.com">Awful Video</a></li><li><a href="/d/cliff-yablonski/">Cliff Yablonski</a></li><li><a href="/booklist/index.htm">My Tank is Fight</a></li><li><a href="/d/directory.php#media">More</a></li></ul></div><div class="item"><h4>Articles</h4><ul><li><a href="/d/awful-movie-database/">Awful Movie Database</a></li><li><a href="/d/second-life-safari/">Secondlife Safari</a></li><li><a href="/d/weekend-web/">Weekend Web</a></li><li><a href="/d/pregame-wrapup/">Pregame Wrapup</a></li><li><a href="/d/icq-pranks/">Pranks (ICQ)</a></li><li><a href="/d/email-pranks/">Pranks (E-mail)</a></li><li><a href="/d/video-game-article/">Video Game Article</a></li><li><a href="/d/directory.php#articles">More</a></li></ul></div><div class="item"><h4>Reviews</h4><ul><li><a href="/d/your-band-sucks/">Your Band Sucks</a></li><li><a href="/d/movie-reviews/">Movie Reviews</a></li><li><a href="/d/hentai-game-reviews/">Awful Anime</a></li><li><a href="/d/rom-pit/">ROM Pit</a></li><li><a href="/d/fashion-swat/">Fashion SWAT</a></li><li><a href="/d/guides/">Guides</a></li><li><a href="/d/game-reviews/">Game Reviews</a></li><li><a href="/d/directory.php#reviews">More</a></li></ul></div><div class="item"><h4>Hosted</h4><ul><li><a href="/hosted/86">#86/68</a></li><li><a href="/hosted/adventures">Daring Armstrong</a></li><li><a href="/hosted/automaticturban">Semi-Automatic Turban</a></li><li><a href="/hosted/cliff">Cliff Yablonski</a></li><li><a href="/hosted/crabs">Leonard Crabs</a></li><li><a href="/hosted/cranky">Cranky Steve</a></li><li><a href="/hosted/drdraw">Dr Draw</a></li><li><a href="/hosted/edbaker">Ed Baker</a></li><li><a href="/hosted/firemancomics">Fireman Comics</a></li><li><a href="/hosted/jeffk">JEFF K</a></li></ul></div><div class="item"><h4>Forums</h4><ul><li><a href="http://forums.somethingawful.com/forumdisplay.php?forumid=1">General Discussion</a></li><li><a href="http://forums.somethingawful.com/forumdisplay.php?forumid=44">Video Games</a></li><li><a href="http://forums.somethingawful.com/forumdisplay.php?forumid=22">Hardware &amp; Software</a></li><li><a href="http://forums.somethingawful.com/forumdisplay.php?forumid=122">Sports</a></li><li><a href="http://forums.somethingawful.com/forumdisplay.php?forumid=133">Movie Reviews</a></li><li><a href="http://forums.somethingawful.com/forumdisplay.php?forumid=150">Music</a></li><li><a href="http://forums.somethingawful.com/forumdisplay.php?forumid=130">TV</a></li><li><a href="http://forums.somethingawful.com/">More</a></li></ul></div></div></div></li></ul></div><div class="brisket"><div class="cavity full top"><div class="organ breadcrumbs"> <a href="/directory/#articles">Articles</a> &gt; <a href="/news/">Front Page News</a></div></div><div class="cavity left"><div class="organ article_meta"><div class="article_head"><h1><a href="/news/assassin-love-poster/">Watch Me Fix The 'Assassin In Love' Movie Poster</a></h1> <span class="date">Tuesday, Jul 25, 2017</span> by <span class="authors"><span class="author"><a href="/author/21/">Dennis &#34;Corin Tucker&#39;s Stalker&#34; Farrell</a> (<a href="http://twitter.com/DennisFarrell" target="_blank">@DennisFarrell</a>)</span></span> </div><div class="social"><div class="twitter_tweet"><a class="twitter-share-button" data-counturl="http://www.somethingawful.com/news/assassin-love-poster/" data-hashtags="somethingawful" data-related="DennisFarrell" data-text="Watch Me Fix The 'Assassin In Love' Movie Poster" data-url="http://www.somethingawful.com/news/assassin-love-poster/" data-via="somethingawful" href="https://twitter.com/share"></a></div><div class="facebook_like"><div class="fb-like" data-font="arial" data-href="http://www.somethingawful.com/news/assassin-love-poster/" data-layout="button_count" data-send="false" data-show-faces="false" data-width="100"></div></div></div></div><div class="organ article"><p><img alt="" class="imgcap" src="http://i.somethingawful.com/u/ctstalker/2017/ailposter1.jpg" width="500"/></p><p><span class="font_big">Honestly, the Assassin In Love poster is nearly perfect to begin with. It just needs a few minor tweaks. For starters, there are too many visual clues about the assassin's profession. Let me edit them out:</span></p><p><span class="font_big"><img alt="" class="imgcap" src="http://i.somethingawful.com/u/ctstalker/2017/ailedit1.jpg" width="598"/><br/> </span></p><p><span class="font_big">The actors' heads are so naturally positioned and so believable that they're a little distracting. When I look at this poster I should think, "That assassin sure is in love!" Instead, I find myself thinking, "Those sure are their heads!"</span></p><p><span class="font_big">Also, that birthday candle on the cake is way too big.</span></p><p><span class="font_big"><img alt="" class="imgcap" src="http://i.somethingawful.com/u/ctstalker/2017/ailedit2.jpg" width="598"/><br/> </span></p><p><span class="font_big">The house in the background is throwing off my sense of scale. It should be far smaller, and closer to the sidewalk.</span></p><p><span class="font_big"><img alt="" class="imgcap" src="http://i.somethingawful.com/u/ctstalker/2017/ailedit4.jpg" width="420"/><br/> </span></p><p><span class="font_big">What does "A killer comedy!" mean? It's such a bizarre, meaningless phrase. This should be replaced with a tagline that tells people what the movie is about.</span></p><p><span class="font_big"><img alt="" class="imgcap" src="http://i.somethingawful.com/u/ctstalker/2017/ailedit3.jpg" width="388"/><br/> </span></p><p><span class="font_big">Now all I have to do is clean up a few stray pixels, and we've got ourselves a poster:</span></p><p><img alt="" class="imgcap" src="http://i.somethingawful.com/u/ctstalker/2017/ailposter2.jpg" width="500"/></p><div class="pb"></div><p class="signoff">–&nbsp;<span class="author"><a href="/author/21/">Dennis &#34;Corin Tucker&#39;s Stalker&#34; Farrell</a> (<a href="http://twitter.com/DennisFarrell" target="_blank">@DennisFarrell</a>)</span></p></div><div class="organ article_nav"> <a class="previous" href="/news/evil-cooper-kadyrov/" title="Was it Ramzan Kadyrov or Evil Dale Cooper?">Previous</a> <a class="more" href="/news/">More Front Page News</a> </div><div class="organ recent_articles"><h4>This Week on Something Awful...</h4><ul class="news"><li><div class="a_info"> <a class="image normal" href="/news/assassin-love-poster/"> <img alt="Watch Me Fix The &#39;Assassin In Love&#39; Movie Poster" class="normal" src="http://i.somethingawful.com/sasbi/promo/00b5d269/2a781b6a/9d3d1522/c6e9d1ad/14821.jpg"> </a> <div class="info"><h3><a href="/news/assassin-love-poster/">Watch Me Fix The 'Assassin In Love' Movie Poster</a> </h3><div class="byline"><span class="date">07-25-2017</span> by <span class="authors"><span class="author"><a href="/author/21/">Dennis &#34;Corin Tucker&#39;s Stalker&#34; Farrell</a></span></span> </div><p>Honestly, the Assassin In Love poster is nearly perfect to begin with. It just needs a few minor tweaks.</p></div><div class="pb"></div></div></li><li><div class="a_info"> <a class="image normal" href="/news/evil-cooper-kadyrov/"> <img alt="Was it Ramzan Kadyrov or Evil Dale Cooper?" class="normal" src="http://i.somethingawful.com/sasbi/promo/69650a61/9af368c1/2a6ee249/47ad7572/14824.jpg"> </a> <div class="info"><h3><a href="/news/evil-cooper-kadyrov/">Was it Ramzan Kadyrov or Evil Dale Cooper?</a> </h3><div class="byline"><span class="date">07-21-2017</span> by <span class="authors"><span class="author"><a href="/author/12/">Zack &#34;Geist Editor&#34; Parsons</a></span></span> </div><p>Evil Cooper and Chechen President Ramzan Kadyrov have both been on a rampage, but who did what?</p></div><div class="pb"></div></div></li></ul><ul class="featured"><li><div class="a_info"> <a class="image small" href="/comedy-goldmine/undead-lich-idiot/"> <img alt="Stupid Liches!" class="small" src="http://i.somethingawful.com/sasbi/promo/58eaa69d/86c0bb41/c0f334b9/5b6c8cf2/14826t.jpg"> </a> <div class="info"><h3><a href="/comedy-goldmine/undead-lich-idiot/">Stupid Liches!</a> </h3><div class="c_name"> <a href="/comedy-goldmine/">Comedy Goldmine</a> </div><p>Liches are huge dumbasses. I do NOT respect liches.</p></div><div class="pb"></div></div></li><li><div class="a_info"> <a class="image small" href="/movie-reviews/sorcerers-apprentice/"> <img alt="The Sorcerer&#39;s Apprentice" class="small" src="http://i.somethingawful.com/sasbi/promo/722fd8c9/7825bdea/860322e2/8ac6dcbd/14825t.png"> </a> <div class="info"><h3><a href="/movie-reviews/sorcerers-apprentice/">The Sorcerer's Apprentice</a> </h3><div class="c_name"> <a href="/movie-reviews/">Reviews [Movies]</a> </div><p>Using the Dark Arts to pants a bully during third form seems kind of wasteful to us, honestly.</p></div><div class="pb"></div></div></li><li><div class="a_info"> <a class="image small" href="/photoshop-phriday/orb-trump-touch/"> <img alt="Trump Touching Orb?" class="small" src="http://i.somethingawful.com/sasbi/promo/24e6e672/1e0a3995/0780dfb8/f91e53ed/14823t.jpg"> </a> <div class="info"><h3><a href="/photoshop-phriday/orb-trump-touch/">Trump Touching Orb?</a> </h3><div class="c_name"> <a href="/photoshop-phriday/">Photoshop Phriday</a> </div><p>Yeah, yeah, I know.</p></div><div class="pb"></div></div></li></ul></div><div class="pb"></div></div><div class="cavity right"><div class="organ adrect"><iframe class="ad" data-unit="right" src="about:blank"></iframe></div><div class="organ "><h3>About This Column</h3><div class="lining"><p>The Something Awful front page news tackles anything both off and on the Internet. Mostly "on" though, as we're all incredible nerds.</p><h4>Previous Articles</h4><ul class="previous_articles"><li><a href="/news/evil-cooper-kadyrov/">Was it Ramzan Kadyrov or Evil Dale Cooper?</a></li><li><a href="/news/eye-contact-lens/">My Eyes Are The Windows 10 To My Soul</a></li><li><a href="/news/foxworthy-body-horror/">You Might Be a Redneck Jokes From the Posthuman Body Horror Awakening</a></li><li><a href="/news/train-riding-tips/">5 Essential Tips for Mass Transit Travel</a></li><li><a href="/news/scary-game-fiction/">Creepypasta_2.wikia.com FEATURED STORIES</a></li></ul><div class="more"><a href="/news/">More</a></div><h4>Suggested Articles</h4><ul class="suggested_articles"><li><a href="/movie-reviews/ninja-turf/1/">Ninja Turf</a></li><li><a href="/current-movie-reviews/paranormal-activity-cross/1/">Paranormal Activity 4; Alex Cross</a></li><li><a href="/movie-reviews/ninja-vengeance/1/">Ninja Vengeance</a></li><li><a href="/movie-reviews/galgameth/1/">Galgameth</a></li><li><a href="/current-movie-reviews/spy-kids-dark/1/">Spy Kids: All the Time in the World in 4D; Don't Be Afraid of the Dark; One Day; Colombiana; Our Idiot Brother; Suing the Devil</a></li></ul></div></div><div class="organ whatshot"><h3>What&#39;s Hot</h3><div class="lining"><ul class="whatshot"><li><a href="/garbage-day/haiku-alphabutt-hinder/1/">Good Riddance, 2008: Haiku Edition! 22-11</a></li><li><a href="/news/evil-cooper-kadyrov/">Was it Ramzan Kadyrov or Evil Dale Cooper?</a></li><li><a href="/game-reviews/blue-stinger-dc/">Blue Stinger (DC)</a></li><li><a href="/feature-articles/athlete-logos-branding/1/">The 9 Athlete Logos Changing How You Will Think About Sports</a></li><li><a href="/comedy-goldmine/chat-to-strangers/1/">Talking to Strangers Online!</a></li></ul></div></div><div class="organ popular_threads"><h3>Popular Threads</h3><div class="lining"><ul class="random"><li><img alt="" height="15" src="https://fi.somethingawful.com/forums/posticons/games-psx-pc.png" width="60"> <a href="http://forums.somethingawful.com/showthread.php?threadid=3827977" title="Dreadnought: World of Space Tanks, but funner'n'at">Dreadnought: World of Space Tanks, but funner'n'at</a></li><li><img alt="" height="15" src="https://fi.somethingawful.com/forums/posticons/cd_action.gif" width="60"> <a href="http://forums.somethingawful.com/showthread.php?threadid=3827979" title="Nuclear annihilation would be cool and good">Nuclear annihilation would be cool and good</a></li><li><img alt="" height="15" src="https://fi.somethingawful.com/forums/posticons/tviv-classic.gif" width="60"> <a href="http://forums.somethingawful.com/showthread.php?threadid=3828000" title="The Super NES Classic Edition comes out in September">The Super NES Classic Edition comes out in September</a></li><li><img alt="" height="15" src="https://fi.somethingawful.com/forums/posticons/wrestlehut-ecw.gif" width="60"> <a href="http://forums.somethingawful.com/showthread.php?threadid=3828005" title="raw with friends">raw with friends</a></li><li><img alt="" height="15" src="https://fi.somethingawful.com/forums/posticons/sports-wwe.gif" width="60"> <a href="http://forums.somethingawful.com/showthread.php?threadid=3828026" title="WWE Discussion is like the Punjabi Prison on 7/24">WWE Discussion is like the Punjabi Prison on 7/24</a></li><li><img alt="" height="15" src="https://fi.somethingawful.com/forums/posticons/icons-08/question.png" width="60"> <a href="http://forums.somethingawful.com/showthread.php?threadid=3828034" title="When did The Office (NBC 2005-2013) Go Downhill?">When did The Office (NBC 2005-2013) Go Downhill?</a></li><li><img alt="" height="15" src="https://fi.somethingawful.com/images/shitpost.gif" width="60"> <a href="http://forums.somethingawful.com/showthread.php?threadid=3827973" title="They are finally going to kill that stupid baby in London">They are finally going to kill that stupid baby in London</a></li><li><img alt="" height="15" src="https://fi.somethingawful.com/forums/posticons/icons-08/event.png" width="60"> <a href="http://forums.somethingawful.com/showthread.php?threadid=3828033" title="got an invite to a HOT CIGAR MEN PARTY, anyone down?(DJ DANO will be there)">got an invite to a HOT CIGAR MEN PARTY, anyone down?(DJ DANO will be there)</a></li></ul></div></div><div class="organ random_articles"><h3>Random Articles</h3><div class="lining"><ul class="random"><li><a href="/music-article/super-bowl-halftime/">The Super Bowl Halftime Show Has Not Gone Far Enough</a></li><li><a href="/flash-tub/educational-computer-vhs/">Computers: Tomorrow's Technology: Today: Part 1: Your Digital Future Starts Today</a></li><li><a href="/news/take-my-katra/">Take My Katra, Please!</a></li><li><a href="/garbage-day/music-next-gimmick/">What Will Be Music's Next Great Gimmick?</a></li><li><a href="/photoshop-phriday/wide-world-insect/1/">Wide World of Insect Sports</a></li></ul><div class="more"><a href="/random/" rel="nofollow">Random!</a></div></div></div><div class="organ side_search"><h3>Search</h3><div class="lining"><form action="/search/" class="site" method="get"><div class="iwrapper"><input name="q" placeholder="Search SA" type="text"/></div><button class="ui small">GO</button> <input name="t" type="hidden" value="0"/> <input name="c" type="hidden" value="0"/> <input name="a" type="hidden" value="0"/> <input name="y" type="hidden" value="0"/> <input name="p" type="hidden" value="1"/></form><form action="/search/amazon/" class="amazon" method="post" target="_blank"><div class="iwrapper"><input name="q" placeholder="Search Amazon" type="text"/></div><button class="ui small">GO</button></form><div class="links"><a class="email" href="mailto:webmaster@somethingawful.com">Email Rich "Lowtax" Kyanka</a> <a class="advertise" href="/feature-articles/something-awful-advertising/">Advertise on SA</a></div></div></div><div class="pb"></div></div><div class="cavity full bottom"><div class="organ ad leaderboard"><iframe class="ad" data-unit="bottom" src="about:blank"></iframe></div></div></div></div></div><div class="rump"><div class="leg"><div class="hoof"><p><strong>Copyright ©2017</strong> Rich "Lowtax" Kyanka &amp; Something Awful LLC.</p><ul><li><a href="mailto:lowtax@somethingawful.com">Email Rich "Lowtax" Kyanka</a></li><li><a href="mailto:advertising@somethingawful.com">Advertise on this site</a></li><li><a href="/feature-articles/website-privacy-policy/">Privacy Statement</a></li><li><a href="/alod/new/">Submit Awful Link</a></li></ul></div></div></div></body></html>