<!DOCTYPE html>
<html>
<head>
<meta charset="utf-8">
<meta content="width=device-width, initial-scale=1.0, maximum-scale=1.0, user-scalable=no" name="viewport">
<meta content="noodp" name="robots">
<script src="/cdn-cgi/apps/head/HUrzTLAxQgicYEiE3OhKRjNWSOg.js"></script><link href="/rss/frontpage.xml" rel="alternate" title="Latest Articles" type="application/rss+xml">
<link href="/rss/video-game-article.xml" rel="alternate" title="Video Game Article" type="application/rss+xml"><meta content="summary" name="twitter:card"><meta content="http://www.somethingawful.com/a/15258/" name="twitter:url"><meta content="Neo Geo Arcade Stick Pro, Darksiders Genesis" name="twitter:title"><meta content="Someone must have spilled the beans about my soft spot for the Neo Geo - a spot encompassing my entire body - because SNK sent me their new Arcade Stick Pro." name="twitter:description"><meta content="http://i.somethingawful.com/sasbi/promo/10d4b366/f410a127/5f7b684f/07a28456/15258.jpg" name="twitter:image"><meta content="@somethingawful" name="twitter:site"><meta content="@DennisFarrell" name="twitter:creator"><meta content="article" property="og:type"><meta content="Something Awful - Neo Geo Arcade Stick Pro, Darksiders Genesis" property="og:title"><meta content="http://www.somethingawful.com/video-game-article/neogeo-darksiders-genesis/" property="og:url"><meta content="http://i.somethingawful.com/sasbi/promo/10d4b366/f410a127/5f7b684f/07a28456/15258.jpg" property="og:image"><meta content="somethingawful.com" property="og:site_name"><meta content="Someone must have spilled the beans about my soft spot for the Neo Geo - a spot encompassing my entire body - because SNK sent me their new Arcade Stick Pro." property="og:description"><meta content="2019-12-11T00:00:00+00:00" property="og:updated_time">
<title>Neo Geo Arcade Stick Pro, Darksiders Genesis</title>
<link href="//static.somethingawful.com/css/main.css" rel="stylesheet" type="text/css">
<link href="https://fonts.googleapis.com/css?family=Roboto" rel="stylesheet">
<!--[if lt IE 8]>
      <link rel="stylesheet" type="text/css" href="//static.somethingawful.com/css/ie.css">
      <![endif]--><script src="//ajax.googleapis.com/ajax/libs/jquery/2.2.2/jquery.min.js" type="text/javascript"><script type="text/javascript" src="https://cdnjs.cloudflare.com/ajax/libs/jquery-migrate/1.4.0/jquery-migrate.min.js"></script></script><script src="//static.somethingawful.com/js/site.min.js" type="text/javascript"></script><script id="twitter-wjs" src="//platform.twitter.com/widgets.js" type="text/javascript"></script><script id="facebook-jssdk" src="//connect.facebook.net/en_US/all.js#xfbml=1" type="text/javascript"></script><script src="//static.somethingawful.com/js/jwplayer/jwplayer.js" type="text/javascript"></script><script src="//static.somethingawful.com/js/article.min.js" type="text/javascript"></script>
</head>
<body class="sa article c_36 a_15258">
<script type="text/javascript">var _gaq = _gaq || [];_gaq.push(['_setAccount', 'UA-33089744-1']);_gaq.push(['_trackPageview']);(function() {var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);})();</script><div class="chuck"><div class="neck"><ul class="scalp"><li><a href="/">Something Awful</a></li><li><a href="https://forums.somethingawful.com/">Something Awful Forums</a></li></ul><div class="head"><a class="logo" href="/"><span>Something Awful</span></a> <iframe class="ad" data-unit="top" src="about:blank"></iframe></div></div></div><div class="sirloin"><div class="ribs"><div class="site-nav"><ul><li class="forums"><a href="https://forums.somethingawful.com/">Forums</a></li><li class="photoshop-phriday"><a href="/photoshop-phriday/"><span class="full">Photoshop Phriday</span><span class="short">Photoshop</span></a></li><li class="comedy-goldmine"><a href="/comedy-goldmine/"><span class="full">Comedy Goldmine</span><span class="short">Goldmine</span></a></li><li class="the-flash-tub"><a href="/flash-tub/"><span class="full">The Flash Tub</span><span class="short">Flash Tub</span></a></li><li class="wtf-dd"><a href="/dungeons-and-dragons/"><span class="full">WTF, D&amp;D?!?</span><span class="short">WTFDD</span></a></li><li class="front-page-articles"><a href="/news/"><span class="full">Front Page Articles</span><span class="short">Front Page</span></a></li><li class="the-everdraed-showcase"><a href="/everdraed-showcase/"><span class="full">The Everdraed Showcase</span><span class="short">Everdraed</span></a></li><li class="video-game-article"><a href="/video-game-article/"><span class="full">Video Game Article</span><span class="short">Video Game</span></a></li><li class="current-releases"><a href="/current-movie-reviews/">Current Releases</a></li><li class="directory"><div class="directory-button"><a href="/directory/">Directory</a><div class="directory"><div class="item"><h4>Media</h4><ul><li><a href="/d/photoshop-phriday/">Photoshop Phriday</a></li><li><a href="/d/flash-tub/">The Flash Tub</a></li><li><a href="/d/comedy-goldmine/">Comedy Goldmine</a></li><li><a href="http://www.centralarc.com">Central ARC</a></li><li><a href="http://www.awfulvideo.com">Awful Video</a></li><li><a href="/d/cliff-yablonski/">Cliff Yablonski</a></li><li><a href="/booklist/index.htm">My Tank is Fight</a></li><li><a href="/d/directory.php#media">More</a></li></ul></div><div class="item"><h4>Articles</h4><ul><li><a href="/d/awful-movie-database/">Awful Movie Database</a></li><li><a href="/d/second-life-safari/">Secondlife Safari</a></li><li><a href="/d/weekend-web/">Weekend Web</a></li><li><a href="/d/pregame-wrapup/">Pregame Wrapup</a></li><li><a href="/d/icq-pranks/">Pranks (ICQ)</a></li><li><a href="/d/email-pranks/">Pranks (E-mail)</a></li><li><a href="/d/video-game-article/">Video Game Article</a></li><li><a href="/d/directory.php#articles">More</a></li></ul></div><div class="item"><h4>Reviews</h4><ul><li><a href="/d/your-band-sucks/">Your Band Sucks</a></li><li><a href="/d/movie-reviews/">Movie Reviews</a></li><li><a href="/d/hentai-game-reviews/">Awful Anime</a></li><li><a href="/d/rom-pit/">ROM Pit</a></li><li><a href="/d/fashion-swat/">Fashion SWAT</a></li><li><a href="/d/guides/">Guides</a></li><li><a href="/d/game-reviews/">Game Reviews</a></li><li><a href="/d/directory.php#reviews">More</a></li></ul></div><div class="item"><h4>Hosted</h4><ul><li><a href="/hosted/86">#86/68</a></li><li><a href="/hosted/adventures">Daring Armstrong</a></li><li><a href="/hosted/automaticturban">Semi-Automatic Turban</a></li><li><a href="/hosted/cliff">Cliff Yablonski</a></li><li><a href="/hosted/crabs">Leonard Crabs</a></li><li><a href="/hosted/cranky">Cranky Steve</a></li><li><a href="/hosted/drdraw">Dr Draw</a></li><li><a href="/hosted/edbaker">Ed Baker</a></li><li><a href="/hosted/firemancomics">Fireman Comics</a></li><li><a href="/hosted/jeffk">JEFF K</a></li></ul></div><div class="item"><h4>Forums</h4><ul><li><a href="https://forums.somethingawful.com/forumdisplay.php?forumid=1">General Discussion</a></li><li><a href="https://forums.somethingawful.com/forumdisplay.php?forumid=44">Video Games</a></li><li><a href="https://forums.somethingawful.com/forumdisplay.php?forumid=22">Hardware &amp; Software</a></li><li><a href="https://forums.somethingawful.com/forumdisplay.php?forumid=122">Sports</a></li><li><a href="https://forums.somethingawful.com/forumdisplay.php?forumid=133">Movie Reviews</a></li><li><a href="https://forums.somethingawful.com/forumdisplay.php?forumid=150">Music</a></li><li><a href="https://forums.somethingawful.com/forumdisplay.php?forumid=130">TV</a></li><li><a href="https://forums.somethingawful.com/">More</a></li></ul></div></div></div></li></ul></div><div class="brisket"><div class="cavity full top"><div class="organ breadcrumbs"> <a href="/directory/#articles">Articles</a> &gt; <a href="/video-game-article/">Video Game Article</a></div></div><div class="cavity left"><div class="organ article_meta"><div class="article_head"><h1><a href="/video-game-article/neogeo-darksiders-genesis/">Neo Geo Arcade Stick Pro, Darksiders Genesis</a></h1> <span class="date">Wednesday, Dec 11, 2019</span> by <span class="authors"><span class="author"><a href="/author/21/">Dennis Farrell</a> (<a href="https://twitter.com/DennisFarrell" target="_blank">@DennisFarrell</a>)</span></span> </div><div class="social"><div class="twitter_tweet"><a class="twitter-share-button" data-counturl="http://www.somethingawful.com/video-game-article/neogeo-darksiders-genesis/" data-hashtags="somethingawful" data-related="DennisFarrell" data-text="Neo Geo Arcade Stick Pro, Darksiders Genesis" data-url="http://www.somethingawful.com/video-game-article/neogeo-darksiders-genesis/" data-via="somethingawful" href="https://twitter.com/share"></a></div><div class="facebook_like"><div class="fb-like" data-font="arial" data-href="http://www.somethingawful.com/video-game-article/neogeo-darksiders-genesis/" data-layout="button_count" data-send="false" data-show-faces="false" data-width="100"></div></div></div></div><div class="organ article"><p><span class="font_big compat68">Neo Geo Arcade Stick Pro</span></p><p>Someone must have spilled the beans about my soft spot for the Neo Geo - a spot encompassing my entire body - because SNK sent me this:</p><p><img alt="" class="center imgcap" src="https://i.somethingawful.com/u/ctstalker/2019/neogeoasp.jpg" width="500" /></p><p>It's the Neo Geo Arcade Stick Pro, which is two things.</p><blockquote class="compat502"><p><b>1.</b> An arcade stick (didn't mean to blow your mind) that can be plugged into your PC via USB</p><p><b>2.</b> A self-contained Neo Geo platform with 20 pre-installed fighting games and HDMI output</p></blockquote><p>Unlike last year's Neo Geo Mini, the stick in this unit is properly clicky. It feels great and hasn't dropped a single input. I'd compare the buttons to those found on a chiclet keyboard. If that bothers you, it's easy to swap them out for some Sanwa/Happ replacements.</p><p>So how does it hold up as a Neo Geo? Not bad! The interface is very "What if the Switch was hit by a Tonka truck":</p><p><img alt="" class="center imgcap" src="https://i.somethingawful.com/u/ctstalker/2019/ngaspint.png" width="400" /></p><p>There are 20 fighting games included, and they all seem to perform as well as they did on the original hardware. I also seem to perform as well as I did on the original hardware, which is to say that I mash buttons in Samurai Shodown 2 and lose with a dopey smile on my face.</p><p>Video output is perfectly clear. Just be sure to use the Pixel Scaling mode. Who in their right mind enables smoothing filters that turn crisp pixel art into a Dali painting viewed through cheesecloth coated in vaseline?</p><p>SNK has promised to unlock an additional 20 games at no additional cost. Unfortunately, that announcement was made in early November and we haven't heard a peep since. If we get Neo Turf Masters and Windjammers on this thing the wait will have been worth it.</p><p>Oh, did I mention that you can hook this stick up to the Neo Geo Mini?</p><p><img alt="" class="center imgcap" src="https://i.somethingawful.com/u/ctstalker/2019/ngmini.jpg" width="500" /></p><p>This definitely isn't the best way to play King of the Monsters, but it is the most preposterous. And therefore the best.</p><p class="compat5"><span class="font_big">Darksiders Genesis</span></p><p>At first I thought Darksiders Genesis would be a Diablo-like ARPG in a coat of Darksiders paint. But no, it's actually a Darksiders-ass Darksiders game with the camera pulled back.</p><p><img alt="" class="right imgcap" src="https://i.somethingawful.com/u/ctstalker/2019/darksidersgenesis.jpg" width="267" />You're not pointing and clicking. You're taking direct control (with a controller if you have any sense whatsoever) to dodge, bounce between enemies, platform, perform accurate jumps and glides, and solve environmental puzzles. You know, Darksiders stuff.</p><p>Speaking of Darksiders stuff, Genesis carries on the fine tradition of absurd cutscenes/cinematics in which demons and divine beings make grand proclamations while oozing with disdain for one another. There's also a lot of sassy attitude on display, which is always welcome.</p><p>Combat is every bit as intricate as you'd hope. There are combos, abilities to unlock, ammo types to switch between, meters that fill up to perform specials, and finishing moves that refill your resources. You can also swap between Strife (a gunslinger) and War (a sword guy) at any time. When you find yourself juggling all these systems in a particularly intense fight and everything comes together it's immensely satisfying.</p><p>I have one gripe. There's a map, which is good. It does not have a marker indicating your current location, which is bad. Every time you pull up the map you need to perform a few seconds of slightly annoying guesswork. Not the end of the world, but you will be doing this often as you explore and scour levels for goodies.</p><p>One reason for this is Creature Cores, which combine the game's skill tree and loot system. You kill stuff to drop cores. You slot those cores in the tree to unlock bonuses. You find and stack additional cores of the same type to level up those bonuses. It's relatively straightforward, giving you a reason to revisit maps (maybe with a co-op buddy, which the game is built around) and blast/hack demons.</p><p>Darksiders Genesis is the most pleasant surprise I've played this year. Oh, and have you heard about the super special Nephilim Edition that comes with a whole dang board game? Like, with miniatures and hexagon tiles? We'll be covering that game (Darksiders: The Forbidden Land) in an upcoming revival of Board Game Article. It's been a long time since we've looked at tabletop stuff, so I'm looking forward to it.</p><p class="compat793"><span class="Apple-style-span compat505"><img alt="" src="https://i.somethingawful.com/u/ctstalker/2008_02/2008_02_23_reviews.png" /></span><br /></p><p class="compat793"><b><img alt="" class="imgcap texttop" src="https://i.somethingawful.com/mjolnir/images/ctstalker%7Evga-icon-pc.gif" width="60" /> Darksiders Genesis<br /> </b>I went into this expecting Darkspore and found SimCopter and also found myself hopelessly lost in a metaphor. <b>8/10</b></p><div class="pb"></div><p class="signoff">–&nbsp;<span class="author"><a href="/author/21/">Dennis Farrell</a> (<a href="https://twitter.com/DennisFarrell" target="_blank">@DennisFarrell</a>)</span></p></div><div class="organ article_nav"> <a class="previous" href="/video-game-article/stranglehold-catering-cart/" title="The Best Game of the 2010s Is John Woo's Stranglehold, From 2007">Previous</a> <a class="more" href="/video-game-article/">More Video Game Article</a> </div><div class="organ recent_articles"><h4>This Week on Something Awful...</h4><ul class="news"><li><div class="a_info"> <a class="image normal" href="/news/something-awful-office/"> <img alt="A Typical Day In The Something Awful Office" class="normal" src="https://i.somethingawful.com/sasbi/promo/b20c50c2/12421071/eb11d08d/99a6048b/15257.jpg"> </a> <div class="info"><h3><a href="/news/something-awful-office/">A Typical Day In The Something Awful Office</a> </h3><div class="byline"><span class="date">12-10-2019</span> by <span class="authors"><span class="author"><a href="/author/21/">Dennis Farrell</a></span></span> </div><p>12AM: Board a personal hyperjet for lunch at Super Olive Garden, the Olive Garden that lays a slice of American cheese on top of every plate of pasta whether you like it or not</p></div><div class="pb"></div></div></li><li><div class="a_info"> <a class="image normal" href="/news/terminator-robot-skull/"> <img alt="The Terminator Resistance Tunnel Message Board" class="normal" src="https://i.somethingawful.com/sasbi/promo/13d4bfa0/321f86f0/42b34ec7/9064b316/15255.jpg"> </a> <div class="info"><h3><a href="/news/terminator-robot-skull/">The Terminator Resistance Tunnel Message Board</a> </h3><div class="byline"><span class="date">12-04-2019</span> by <span class="authors"><span class="author"><a href="/author/21/">Dennis Farrell</a></span></span> </div><p>REMINDER: If you leave a skull lying around up on the surface it will get robo-stomped for sure. We&#39;ve all seen how much those robots love to crush a cranium beneath a mechanical heel and glare around dramatically. Keep your skulls on shelves, people!</p></div><div class="pb"></div></div></li></ul><ul class="featured"><li><div class="a_info"> <a class="image small" href="/video-game-article/neogeo-darksiders-genesis/"> <img alt="Neo Geo Arcade Stick Pro, Darksiders Genesis" class="small" src="https://i.somethingawful.com/sasbi/promo/10d4b366/f410a127/5f7b684f/07a28456/15258t.jpg"> </a> <div class="info"><h3><a href="/video-game-article/neogeo-darksiders-genesis/">Neo Geo Arcade Stick Pro, Darksiders Genesis</a> </h3><div class="c_name"> <a href="/video-game-article/">Video Game Article</a> </div><p>Both are big, ridiculous, colorful, and surprisingly great.</p></div><div class="pb"></div></div></li><li><div class="a_info"> <a class="image small" href="/photoshop-phriday/romance-covers-1/"> <img alt="Romance Novels!" class="small" src="https://i.somethingawful.com/sasbi/promo/ebd75b89/70e12771/b1aab92e/b59cf0c2/15256t.jpg"> </a> <div class="info"><h3><a href="/photoshop-phriday/romance-covers-1/">Romance Novels!</a> </h3><div class="c_name"> <a href="/photoshop-phriday/">Photoshop Phriday</a> </div><p>Fuck around with antique smut and save big, only on SomethingAwful.com!</p></div><div class="pb"></div></div></li><li><div class="a_info"> <a class="image small" href="/photoshop-phriday/awful-propaganda-2/"> <img alt="Awful Propaganda Part 2" class="small" src="https://i.somethingawful.com/sasbi/promo/fb506ffc/6e2e1c23/6f9b26dc/b5dcc862/15251t.jpg"> </a> <div class="info"><h3><a href="/photoshop-phriday/awful-propaganda-2/">Awful Propaganda Part 2</a> </h3><div class="c_name"> <a href="/photoshop-phriday/">Photoshop Phriday</a> </div><p>War posters + forums posters = insert punchline here!</p></div><div class="pb"></div></div></li></ul></div><div class="pb"></div></div><div class="cavity right"><div class="organ adrect"><iframe class="ad" data-unit="right" src="about:blank"></iframe></div><div class="organ "><h3>About This Column</h3><div class="lining"><p>The cutting edge of video game articles.</p><h4>Previous Articles</h4><ul class="previous_articles"><li><a href="/video-game-article/stranglehold-catering-cart/">The Best Game of the 2010s Is John Woo's Stranglehold, From 2007</a></li><li><a href="/video-game-article/mega-sg-genesis/">Analogue's Mega Sg: Tommy Lasorda Never Looked So Good</a></li><li><a href="/video-game-article/outer-worlds-disco/">The Outer Worlds Review</a></li><li><a href="/video-game-article/xbox-mod-ssd/">Old Games On New TVs: The Original, Huge, Xbox</a></li><li><a href="/video-game-article/goose-game-patch/">Patch Notes: Untitled Goose Game</a></li></ul><div class="more"><a href="/video-game-article/">More</a></div><h4>Suggested Articles</h4><ul class="suggested_articles"><li><a href="/movie-reviews/madness-japan/1/">Awful Movie Madness: Japan</a></li><li><a href="/current-movie-reviews/jack-giant-slayer/1/">Jack the Giant Slayer; 21 and Over; The Last Exorcism Part II; Stoker; Snitch</a></li><li><a href="/current-movie-reviews/grey-man-ledge/1/">The Grey; Man on a Ledge; One For the Money; Albert Nobbs</a></li><li><a href="/current-movie-reviews/maze-tombstones-tusk/1/">The Maze Runner; A Walk Among the Tombstones; This Is Where I Leave You; Tusk</a></li><li><a href="/awfulvision/autism-sonic-brony/1/">Stay hydrated, Homies!</a></li></ul></div></div><div class="organ whatshot"><h3>What&#39;s Hot</h3><div class="lining"><ul class="whatshot"><li><a href="/video-game-article/neogeo-darksiders-genesis/">Neo Geo Arcade Stick Pro, Darksiders Genesis</a></li><li><a href="/comedy-goldmine/drwho-episode-ideas/1/">Dr. Who: Future Episodes Revealed!</a></li><li><a href="/dungeons-and-dragons/magic-antiquities-arabian/1/">Magic the Gathering: Arabian Nights (1993) and Antiquities (1994)</a></li><li><a href="/feature-articles/week-life-ithe/1/">A Week in the Life of &lt;i&gt;The Sims&lt;/i&gt;</a></li><li><a href="/dungeons-and-dragons/vampire-artwork-montreal/1/">More Art of Vampire: The Maquerade (1990s)</a></li></ul></div></div><div class="organ popular_threads"><h3>Popular Threads</h3><div class="lining"><ul class="random"><li><img alt="" height="15" src="https://fi.somethingawful.com/forums/posticons/lf-fuckit3.gif" width="60"> <a href="https://forums.somethingawful.com/showthread.php?threadid=3906733" title="Democracy Manifest">Democracy Manifest</a></li><li><img alt="" height="15" src="https://fi.somethingawful.com/forums/posticons/byob-gents.gif" width="60"> <a href="https://forums.somethingawful.com/showthread.php?threadid=3906758" title="Holiday Pet Pics">Holiday Pet Pics</a></li><li><img alt="" height="15" src="https://fi.somethingawful.com/forums/posticons/byob-safespace.gif" width="60"> <a href="https://forums.somethingawful.com/showthread.php?threadid=3906689" title="safety and weed bong thread">safety and weed bong thread</a></li><li><img alt="" height="15" src="https://fi.somethingawful.com/forums/posticons/byob-slayer.gif" width="60"> <a href="https://forums.somethingawful.com/showthread.php?threadid=3906669" title="hello and welcome to fatty mcfatfat day">hello and welcome to fatty mcfatfat day</a></li><li><img alt="" height="15" src="https://fi.somethingawful.com/forums/posticons/cd_comedy.gif" width="60"> <a href="https://forums.somethingawful.com/showthread.php?threadid=3906697" title="Irony free cum town thread">Irony free cum town thread</a></li><li><img alt="" height="15" src="https://fi.somethingawful.com/forums/posticons/ap-website.png" width="60"> <a href="https://forums.somethingawful.com/showthread.php?threadid=3906637" title="let's talk about build systems">let's talk about build systems</a></li><li><img alt="" height="15" src="https://fi.somethingawful.com/forums/posticons/ml-dumbass.gif" width="60"> <a href="https://forums.somethingawful.com/showthread.php?threadid=3906638" title="Hi! My mom is insane!">Hi! My mom is insane!</a></li><li><img alt="" height="15" src="https://fi.somethingawful.com/forums/posticons/byob-gents.gif" width="60"> <a href="https://forums.somethingawful.com/showthread.php?threadid=3906676" title="Red Flags to pass down to the youth">Red Flags to pass down to the youth</a></li></ul></div></div><div class="organ random_articles"><h3>Random Articles</h3><div class="lining"><ul class="random"><li><a href="/movie-reviews/red-faction-origins/1/">Red Faction: Origins</a></li><li><a href="/news/nazi-thanksgiving-dinner/">Can We Get Through One Thanksgiving Without Hearing the Word &quot;Nazi&quot;?</a></li><li><a href="/state-og/state-og-update-119/">State Og Update: 10.22.05</a></li><li><a href="/comedy-goldmine/letters-to-santa/1/">Letters To Santa</a></li><li><a href="/awful-links/retard-card-baseball/">Retard Card</a></li></ul><div class="more"><a href="/random/" rel="nofollow">Random!</a></div></div></div><div class="organ side_search"><h3>Search</h3><div class="lining"><form action="/search/" class="site" method="get"><div class="iwrapper"><input name="q" placeholder="Search SA" type="text" /></div><button class="ui small">GO</button> <input name="t" type="hidden" value="0" /> <input name="c" type="hidden" value="0" /> <input name="a" type="hidden" value="0" /> <input name="y" type="hidden" value="0" /> <input name="p" type="hidden" value="1" /></form><form action="/search/amazon/" class="amazon" method="post" target="_blank"><div class="iwrapper"><input name="q" placeholder="Search Amazon" type="text" /></div><button class="ui small">GO</button></form><div class="links"><a class="email" href="mailto:webmaster@somethingawful.com">Email Rich "Lowtax" Kyanka</a> <a class="advertise" href="/feature-articles/something-awful-advertising/">Advertise on SA</a></div></div></div><div class="pb"></div></div><div class="cavity full bottom"><div class="organ ad leaderboard"><iframe class="ad" data-unit="bottom" src="about:blank"></iframe></div></div></div></div></div><div class="rump"><div class="leg"><div class="hoof"><p><strong>Copyright ©2019</strong> Rich "Lowtax" Kyanka &amp; Something Awful LLC.</p><ul><li><a href="mailto:lowtax@somethingawful.com">Email Rich "Lowtax" Kyanka</a></li><li><a href="mailto:advertising@somethingawful.com">Advertise on this site</a></li><li><a href="/feature-articles/website-privacy-policy/">Privacy Statement</a></li><li><a href="/alod/new/">Submit Awful Link</a></li></ul></div></div></div>

</body>
</html>