<!DOCTYPE html>
<html>
<head>
<meta charset="utf-8">
<meta content="width=device-width, initial-scale=1.0, maximum-scale=1.0, user-scalable=no" name="viewport">
<meta content="noodp" name="robots">
<script src="/cdn-cgi/apps/head/6raEY-__bkmuwBZCvQmrEthUjm0.js"></script><link href="/rss/frontpage.xml" rel="alternate" title="Latest Articles" type="application/rss+xml">
<link href="/rss/news.xml" rel="alternate" title="Front Page News" type="application/rss+xml"><meta content="summary" name="twitter:card"><meta content="http://www.somethingawful.com/a/15066/" name="twitter:url"><meta content="Daisy Hogg, would you do me the honor of accompanying me and my AR-15 to prom?" name="twitter:title"><meta content="M&#39;lady, would thou deign to accompany me and my ArmaLite Rifle under the sea this prom?" name="twitter:description"><meta content="http://i.somethingawful.com/sasbi/promo/141c3ffe/dc2e23e6/cdfb31a4/56bed268/15066newsimg.jpg" name="twitter:image"><meta content="@somethingawful" name="twitter:site"><meta content="@sexyfacts4u" name="twitter:creator"><meta content="article" property="og:type"><meta content="Something Awful - Daisy Hogg, would you do me the honor of accompanying me and my AR-15 to prom?" property="og:title"><meta content="http://www.somethingawful.com/news/daisy-hogg-prom/" property="og:url"><meta content="http://i.somethingawful.com/sasbi/promo/141c3ffe/dc2e23e6/cdfb31a4/56bed268/15066newsimg.jpg" property="og:image"><meta content="somethingawful.com" property="og:site_name"><meta content="M&#39;lady, would thou deign to accompany me and my ArmaLite Rifle under the sea this prom?" property="og:description"><meta content="2018-08-31T12:16:15+00:00" property="og:updated_time">
<title>Daisy Hogg, would you do me the honor of accompanying me and my AR-15 to prom?</title>
<link href="//static.somethingawful.com/css/main.css" rel="stylesheet" type="text/css">
<link href="https://fonts.googleapis.com/css?family=Roboto" rel="stylesheet">
<!--[if lt IE 8]>
      <link rel="stylesheet" type="text/css" href="//static.somethingawful.com/css/ie.css">
      <![endif]--><script src="//ajax.googleapis.com/ajax/libs/jquery/2.2.2/jquery.min.js" type="text/javascript"><script type="text/javascript" src="https://cdnjs.cloudflare.com/ajax/libs/jquery-migrate/1.4.0/jquery-migrate.min.js"></script></script><script src="//static.somethingawful.com/js/site.min.js" type="text/javascript"></script><script id="twitter-wjs" src="//platform.twitter.com/widgets.js" type="text/javascript"></script><script id="facebook-jssdk" src="//connect.facebook.net/en_US/all.js#xfbml=1" type="text/javascript"></script><script src="//static.somethingawful.com/js/jwplayer/jwplayer.js" type="text/javascript"></script><script src="//static.somethingawful.com/js/article.min.js" type="text/javascript"></script>
</head>
<body class="sa article c_63 a_15066">
<script type="text/javascript">var _gaq = _gaq || [];_gaq.push(['_setAccount', 'UA-33089744-1']);_gaq.push(['_trackPageview']);(function() {var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);})();</script><div class="chuck"><div class="neck"><ul class="scalp"><li><a href="/">Something Awful</a></li><li><a href="https://forums.somethingawful.com/">Something Awful Forums</a></li></ul><div class="head"><a class="logo" href="/"><span>Something Awful</span></a> <iframe class="ad" data-unit="top" src="about:blank"></iframe></div></div></div><div class="sirloin"><div class="ribs"><div class="site-nav"><ul><li class="forums"><a href="https://forums.somethingawful.com/">Forums</a></li><li class="photoshop-phriday"><a href="/photoshop-phriday/"><span class="full">Photoshop Phriday</span><span class="short">Photoshop</span></a></li><li class="comedy-goldmine"><a href="/comedy-goldmine/"><span class="full">Comedy Goldmine</span><span class="short">Goldmine</span></a></li><li class="the-flash-tub"><a href="/flash-tub/"><span class="full">The Flash Tub</span><span class="short">Flash Tub</span></a></li><li class="wtf-dd"><a href="/dungeons-and-dragons/"><span class="full">WTF, D&amp;D?!?</span><span class="short">WTFDD</span></a></li><li class="front-page-articles"><a href="/news/"><span class="full">Front Page Articles</span><span class="short">Front Page</span></a></li><li class="the-everdraed-showcase"><a href="/everdraed-showcase/"><span class="full">The Everdraed Showcase</span><span class="short">Everdraed</span></a></li><li class="video-game-article"><a href="/video-game-article/"><span class="full">Video Game Article</span><span class="short">Video Game</span></a></li><li class="current-releases"><a href="/current-movie-reviews/">Current Releases</a></li><li class="directory"><div class="directory-button"><a href="/directory/">Directory</a><div class="directory"><div class="item"><h4>Media</h4><ul><li><a href="/d/photoshop-phriday/">Photoshop Phriday</a></li><li><a href="/d/flash-tub/">The Flash Tub</a></li><li><a href="/d/comedy-goldmine/">Comedy Goldmine</a></li><li><a href="http://www.centralarc.com">Central ARC</a></li><li><a href="http://www.awfulvideo.com">Awful Video</a></li><li><a href="/d/cliff-yablonski/">Cliff Yablonski</a></li><li><a href="/booklist/index.htm">My Tank is Fight</a></li><li><a href="/d/directory.php#media">More</a></li></ul></div><div class="item"><h4>Articles</h4><ul><li><a href="/d/awful-movie-database/">Awful Movie Database</a></li><li><a href="/d/second-life-safari/">Secondlife Safari</a></li><li><a href="/d/weekend-web/">Weekend Web</a></li><li><a href="/d/pregame-wrapup/">Pregame Wrapup</a></li><li><a href="/d/icq-pranks/">Pranks (ICQ)</a></li><li><a href="/d/email-pranks/">Pranks (E-mail)</a></li><li><a href="/d/video-game-article/">Video Game Article</a></li><li><a href="/d/directory.php#articles">More</a></li></ul></div><div class="item"><h4>Reviews</h4><ul><li><a href="/d/your-band-sucks/">Your Band Sucks</a></li><li><a href="/d/movie-reviews/">Movie Reviews</a></li><li><a href="/d/hentai-game-reviews/">Awful Anime</a></li><li><a href="/d/rom-pit/">ROM Pit</a></li><li><a href="/d/fashion-swat/">Fashion SWAT</a></li><li><a href="/d/guides/">Guides</a></li><li><a href="/d/game-reviews/">Game Reviews</a></li><li><a href="/d/directory.php#reviews">More</a></li></ul></div><div class="item"><h4>Hosted</h4><ul><li><a href="/hosted/86">#86/68</a></li><li><a href="/hosted/adventures">Daring Armstrong</a></li><li><a href="/hosted/automaticturban">Semi-Automatic Turban</a></li><li><a href="/hosted/cliff">Cliff Yablonski</a></li><li><a href="/hosted/crabs">Leonard Crabs</a></li><li><a href="/hosted/cranky">Cranky Steve</a></li><li><a href="/hosted/drdraw">Dr Draw</a></li><li><a href="/hosted/edbaker">Ed Baker</a></li><li><a href="/hosted/firemancomics">Fireman Comics</a></li><li><a href="/hosted/jeffk">JEFF K</a></li></ul></div><div class="item"><h4>Forums</h4><ul><li><a href="https://forums.somethingawful.com/forumdisplay.php?forumid=1">General Discussion</a></li><li><a href="https://forums.somethingawful.com/forumdisplay.php?forumid=44">Video Games</a></li><li><a href="https://forums.somethingawful.com/forumdisplay.php?forumid=22">Hardware &amp; Software</a></li><li><a href="https://forums.somethingawful.com/forumdisplay.php?forumid=122">Sports</a></li><li><a href="https://forums.somethingawful.com/forumdisplay.php?forumid=133">Movie Reviews</a></li><li><a href="https://forums.somethingawful.com/forumdisplay.php?forumid=150">Music</a></li><li><a href="https://forums.somethingawful.com/forumdisplay.php?forumid=130">TV</a></li><li><a href="https://forums.somethingawful.com/">More</a></li></ul></div></div></div></li></ul></div><div class="brisket"><div class="cavity full top"><div class="organ breadcrumbs"> <a href="/directory/#articles">Articles</a> &gt; <a href="/news/">Front Page News</a></div></div><div class="cavity left"><div class="organ article_meta"><div class="article_head"><h1><a href="/news/daisy-hogg-prom/">Daisy Hogg, would you do me the honor of accompanying me and my AR-15 to prom?</a></h1> <span class="date">Friday, Aug 31, 2018</span> by <span class="authors"><span class="author"><a href="/author/12/">Hoggluvr</a> (<a href="https://twitter.com/sexyfacts4u" target="_blank">@sexyfacts4u</a>)</span></span> </div><div class="social"><div class="twitter_tweet"><a class="twitter-share-button" data-counturl="http://www.somethingawful.com/news/daisy-hogg-prom/" data-hashtags="somethingawful" data-related="sexyfacts4u" data-text="Daisy Hogg, would you do me the honor of accompanying me and my AR-15 to prom?" data-url="http://www.somethingawful.com/news/daisy-hogg-prom/" data-via="somethingawful" href="https://twitter.com/share"></a></div><div class="facebook_like"><div class="fb-like" data-font="arial" data-href="http://www.somethingawful.com/news/daisy-hogg-prom/" data-layout="button_count" data-send="false" data-show-faces="false" data-width="100"></div></div></div></div><div class="organ article"><div><img alt="" class="center imgcap" src="https://i.somethingawful.com/u/elpintogrande/112017/daisy2.jpg" width="635" /><br /></div><div><img alt="" class="right imgcap" src="https://i.somethingawful.com/u/elpintogrande/112017/daisy1_1.jpg" width="270" />I know we have only known each other since I turned pictures of David Hogg into a girl just a couple weeks ago, but I was hoping, hat-in-hand that you would do me the supreme honor of being my date to the prom this year.<br /></div><p><br /> The thing is, Daisy, we live in an open carry state and I am of legal age to comport myself in the public locations with my trusty AR-15 to defend myself. Well, ever since we found out where the school board lives and threatened all their children they have been forced to remove the gun free zone around schools. Which means for the first time I can feel safe under the sea open carrying at prom. That's the prom theme this year. I do not swim into the ocean because of an email I saw about weird fish.<br /></p><p>I was wondering - praying, truth be told - if you would accompany me and my ArmaLite Rifle. You're so pretty and, well, I have been following you on hoggwatch ever since that school shooting. For a long time I wanted to beat you up good or shoot holes in you or order a bunch of pizzas to your house late at night. But since I made you into a girl in a picture, my feelings have changed for you.<br /></p><p>By god, my heart is singing for you, Daisy. I just don't know if I can bear to go to prom without you. Since I have already personified my beautiful long gun, let's make 2 and 2 equal 3 like sweet Remington said and go to that prom as a trio.<br /></p><p>Some might say I am living in an insane 21st century fantasy hellworld where I turned the survivor of a massacre into a political and sexual fetish object by transforming him into a girl who loves guns. But those people have never held an AR-15 like I want to hold you. Not like you, Daisy. You know the truth.<br /></p><div>So let's Make Prom Great Again together. And if things happen after prom, things that maybe are exciting and unexpected, like we get to shoot a black teenager together in self defense. Well, sometimes fantasies do come true.</div><div><br /></div><div><img alt="" class="center imgcap" src="https://i.somethingawful.com/u/elpintogrande/112017/daisy4.jpg" width="600" /><br /></div><div class="pb"></div><p class="signoff">–&nbsp;<span class="author"><a href="/author/12/">Hoggluvr</a> (<a href="https://twitter.com/sexyfacts4u" target="_blank">@sexyfacts4u</a>)</span></p></div><div class="organ article_nav"> <a class="previous" href="/news/recovering-catholic/" title="My Ongoing Battle Recovering From Catholicism; I Jacked It To the JC Penny's Catalogue">Previous</a> <a class="more" href="/news/">More Front Page News</a> </div><div class="organ recent_articles"><h4>This Week on Something Awful...</h4><ul class="news"><li><div class="a_info"> <a class="image normal" href="/news/daisy-hogg-prom/"> <img alt="Daisy Hogg, would you do me the honor of accompanying me and my AR-15 to prom?" class="normal" src="https://i.somethingawful.com/sasbi/promo/141c3ffe/dc2e23e6/cdfb31a4/56bed268/15066.jpg"> </a> <div class="info"><h3><a href="/news/daisy-hogg-prom/">Daisy Hogg, would you do me the honor of accompanying me and my AR-15 to prom?</a> </h3><div class="byline"><span class="date">08-31-2018</span> by <span class="authors"><span class="author"><a href="/author/12/">Hoggluvr</a></span></span> </div><p>M&#39;lady, would thou deign to accompany me and my ArmaLite Rifle under the sea this prom?</p></div><div class="pb"></div></div></li><li><div class="a_info"> <a class="image normal" href="/news/recovering-catholic/"> <img alt="My Ongoing Battle Recovering From Catholicism; I Jacked It To the JC Penny&#39;s Catalogue" class="normal" src="https://i.somethingawful.com/sasbi/promo/668f5146/78c7e7f5/e71a0704/4935d94c/15065.jpg"> </a> <div class="info"><h3><a href="/news/recovering-catholic/">My Ongoing Battle Recovering From Catholicism; I Jacked It To the JC Penny's Catalogue</a> </h3><div class="byline"><span class="date">08-30-2018</span> by <span class="authors"><span class="author"><a href="/author/3/">Rich &#34;Lowtax&#34; Kyanka</a></span></span> </div><p>I&#39;ll be the first to admit that, during my teenage years, I jacked off while looking at JC Penny&#39;s catalogues. Hell, I still do. The absolute only time I can get off anymore is when I force my wife to dress up like a JC Penny&#39;s catalogue. She doesn&#39;t really enjoy it, but it gives me an excuse to temporarily unchain her from the radiator.</p></div><div class="pb"></div></div></li></ul><ul class="featured"><li><div class="a_info"> <a class="image small" href="/video-game-article/warcraft-battle-azeroth/"> <img alt="After 10 Dang Years Away From World of Warcraft, Here&#39;s My Battle for Azeroth Review" class="small" src="https://i.somethingawful.com/sasbi/promo/0b7e2607/202cb7ca/fc1afda7/ba96a535/15060t.jpg"> </a> <div class="info"><h3><a href="/video-game-article/warcraft-battle-azeroth/">After 10 Dang Years Away From World of Warcraft, Here's My Battle for Azeroth Review</a> </h3><div class="c_name"> <a href="/video-game-article/">Video Game Article</a> </div><p>Guess what&#39;s back? Frosty tundras! And me.</p></div><div class="pb"></div></div></li><li><div class="a_info"> <a class="image small" href="/video-game-article/bonk-sequel-titles/"> <img alt="There Should Have Been 32 Additional Bonk Sequels, And I Came Up With Titles For All of Them" class="small" src="https://i.somethingawful.com/sasbi/promo/cf57d08a/99417090/7f4f367c/647e075e/15050t.jpg"> </a> <div class="info"><h3><a href="/video-game-article/bonk-sequel-titles/">There Should Have Been 32 Additional Bonk Sequels, And I Came Up With Titles For All of Them</a> </h3><div class="c_name"> <a href="/video-game-article/">Video Game Article</a> </div><p>Bonk: The Only Good Bonk Is A Head Bonk</p></div><div class="pb"></div></div></li><li><div class="a_info"> <a class="image small" href="/video-game-article/one-sentence-reviews/"> <img alt="The One Sentence Review Special: More Reviews Than It&#39;s Humanly Possible To Read!" class="small" src="https://i.somethingawful.com/sasbi/promo/fbf8ca43/dcc014c2/c94549d6/b8ca0375/15042t.png"> </a> <div class="info"><h3><a href="/video-game-article/one-sentence-reviews/">The One Sentence Review Special: More Reviews Than It's Humanly Possible To Read!</a> </h3><div class="c_name"> <a href="/video-game-article/">Video Game Article</a> </div><p>We review every game from the last 2 months, plus all 21 SNES Classic titles</p></div><div class="pb"></div></div></li></ul></div><div class="pb"></div></div><div class="cavity right"><div class="organ adrect"><iframe class="ad" data-unit="right" src="about:blank"></iframe></div><div class="organ "><h3>About This Column</h3><div class="lining"><p>The Something Awful front page news tackles anything both off and on the Internet. Mostly "on" though, as we're all incredible nerds.</p><h4>Previous Articles</h4><ul class="previous_articles"><li><a href="/news/recovering-catholic/">My Ongoing Battle Recovering From Catholicism; I Jacked It To the JC Penny's Catalogue</a></li><li><a href="/news/radiohead-yorke-dungeons/">Thom Yorke Playing Dungeons &amp; Dragons</a></li><li><a href="/news/papa-john-ceo/">I am being censored from the Papa John's board meetings by the Deep State</a></li><li><a href="/news/sorry-not-sorry/">I'm So Sorry (If You Were Offended)</a></li><li><a href="/news/stupidass-teenager/">BREAKING NEWS: Stupid Ass Teenager Mortally Injured In Stupid Ass Viral Challenge</a></li></ul><div class="more"><a href="/news/">More</a></div></div></div><div class="organ whatshot"><h3>What&#39;s Hot</h3><div class="lining"><ul class="whatshot"><li><a href="/news/sorry-not-sorry/">I'm So Sorry (If You Were Offended)</a></li><li><a href="/comedy-goldmine/inoffensive-bumper-stickers/1/">Inoffensive Bumper Stickers!</a></li><li><a href="/news/mail-order-husband/">Exotic Mail Order Husbands</a></li><li><a href="/video-game-article/one-sentence-reviews/">The One Sentence Review Special: More Reviews Than It's Humanly Possible To Read!</a></li><li><a href="/news/stupidass-teenager/">BREAKING NEWS: Stupid Ass Teenager Mortally Injured In Stupid Ass Viral Challenge</a></li></ul></div></div><div class="organ popular_threads"><h3>Popular Threads</h3><div class="lining"><ul class="random"><li><img alt="" height="15" src="https://fi.somethingawful.com/forums/posticons/icons-08/photoshop.png" width="60"> <a href="https://forums.somethingawful.com/showthread.php?threadid=3867362" title="Animals in Serious Situations">Animals in Serious Situations</a></li><li><img alt="" height="15" src="https://fi.somethingawful.com/forums/posticons/icons-08/gross.png" width="60"> <a href="https://forums.somethingawful.com/showthread.php?threadid=3867444" title="Love in the Autumn Years">Love in the Autumn Years</a></li><li><img alt="" height="15" src="https://fi.somethingawful.com/images/shitpost.gif" width="60"> <a href="https://forums.somethingawful.com/showthread.php?threadid=3867400" title="I am looking for a particular extreme 1990s Old El Paso taco commercial">I am looking for a particular extreme 1990s Old El Paso taco commercial</a></li><li><img alt="" height="15" src="https://fi.somethingawful.com/forums/posticons/lf-marx.png" width="60"> <a href="https://forums.somethingawful.com/showthread.php?threadid=3867443" title="September TRUMP THREAD">September TRUMP THREAD</a></li><li><img alt="" height="15" src="https://fi.somethingawful.com/forums/posticons/sports-nfl.gif" width="60"> <a href="https://forums.somethingawful.com/showthread.php?threadid=3867454" title="DSYS 2018: Weekly Sit/Start Thread">DSYS 2018: Weekly Sit/Start Thread</a></li><li><img alt="" height="15" src="https://fi.somethingawful.com/forums/posticons/icons-08/drugs.png" width="60"> <a href="https://forums.somethingawful.com/showthread.php?threadid=3867459" title="Should I kick my roommate out even if he doesn't have any options?">Should I kick my roommate out even if he doesn't have any options?</a></li><li><img alt="" height="15" src="https://fi.somethingawful.com/forums/posticons/qcs-green.gif" width="60"> <a href="https://forums.somethingawful.com/showthread.php?threadid=3867410" title="ITT I will assign you a picture of a person and say you are that person">ITT I will assign you a picture of a person and say you are that person</a></li><li><img alt="" height="15" src="https://fi.somethingawful.com/forums/posticons/games-f2p.gif" width="60"> <a href="https://forums.somethingawful.com/showthread.php?threadid=3867392" title="Dragalia Lost: Make pacts with buff, sexy dragons">Dragalia Lost: Make pacts with buff, sexy dragons</a></li></ul></div></div><div class="organ random_articles"><h3>Random Articles</h3><div class="lining"><ul class="random"><li><a href="/news/prank-family-scandal/">Pranks Are Tearing Our Prank Family Apart</a></li><li><a href="/news/party-guide/">Some Types of Parties</a></li><li><a href="/awful-links/awful-link-1696/">Jumpy's Music</a></li><li><a href="/livejournal-theater/life-of-axle/">A Day In the Life of Axle</a></li><li><a href="/news/roamin-dad-11/">Subj: LETS TALK TURKEY WITH DAD</a></li></ul><div class="more"><a href="/random/" rel="nofollow">Random!</a></div></div></div><div class="organ side_search"><h3>Search</h3><div class="lining"><form action="/search/" class="site" method="get"><div class="iwrapper"><input name="q" placeholder="Search SA" type="text" /></div><button class="ui small">GO</button> <input name="t" type="hidden" value="0" /> <input name="c" type="hidden" value="0" /> <input name="a" type="hidden" value="0" /> <input name="y" type="hidden" value="0" /> <input name="p" type="hidden" value="1" /></form><form action="/search/amazon/" class="amazon" method="post" target="_blank"><div class="iwrapper"><input name="q" placeholder="Search Amazon" type="text" /></div><button class="ui small">GO</button></form><div class="links"><a class="email" href="mailto:webmaster@somethingawful.com">Email Rich "Lowtax" Kyanka</a> <a class="advertise" href="/feature-articles/something-awful-advertising/">Advertise on SA</a></div></div></div><div class="pb"></div></div><div class="cavity full bottom"><div class="organ ad leaderboard"><iframe class="ad" data-unit="bottom" src="about:blank"></iframe></div></div></div></div></div><div class="rump"><div class="leg"><div class="hoof"><p><strong>Copyright ©2018</strong> Rich "Lowtax" Kyanka &amp; Something Awful LLC.</p><ul><li><a href="mailto:lowtax@somethingawful.com">Email Rich "Lowtax" Kyanka</a></li><li><a href="mailto:advertising@somethingawful.com">Advertise on this site</a></li><li><a href="/feature-articles/website-privacy-policy/">Privacy Statement</a></li><li><a href="/alod/new/">Submit Awful Link</a></li></ul></div></div></div>

</body>
</html>