<!DOCTYPE html>
<html>
<head>
<meta charset="utf-8">
<meta content="width=device-width, initial-scale=1.0, maximum-scale=1.0, user-scalable=no" name="viewport">
<meta content="noodp" name="robots">
<script src="/cdn-cgi/apps/head/611UpADCMrSHVdkHC89tAQ4KMI8.js"></script><link href="/rss/frontpage.xml" rel="alternate" title="Latest Articles" type="application/rss+xml">
<link href="/rss/news.xml" rel="alternate" title="Front Page News" type="application/rss+xml"><meta content="summary" name="twitter:card"><meta content="http://www.somethingawful.com/a/15188/" name="twitter:url"><meta content="That New Alien Tabletop RPG Seems Familiar" name="twitter:title"><meta content="Holding high a gnarled staff wreath with holly, an elf summons the fury of the storm and calls down explosive bolts of lightning to smite the torch-carrying ALIENS who threaten her forest." name="twitter:description"><meta content="http://i.somethingawful.com/sasbi/promo/8a20d7c7/b4ca634d/08739cf6/14e6063c/15188newsimg.jpg" name="twitter:image"><meta content="@somethingawful" name="twitter:site"><meta content="@DennisFarrell" name="twitter:creator"><meta content="article" property="og:type"><meta content="Something Awful - That New Alien Tabletop RPG Seems Familiar" property="og:title"><meta content="http://www.somethingawful.com/news/alien-rpg-dungeon/" property="og:url"><meta content="http://i.somethingawful.com/sasbi/promo/8a20d7c7/b4ca634d/08739cf6/14e6063c/15188newsimg.jpg" property="og:image"><meta content="somethingawful.com" property="og:site_name"><meta content="Holding high a gnarled staff wreath with holly, an elf summons the fury of the storm and calls down explosive bolts of lightning to smite the torch-carrying ALIENS who threaten her forest." property="og:description"><meta content="2019-05-28T00:00:00+00:00" property="og:updated_time">
<title>That New Alien Tabletop RPG Seems Familiar</title>
<link href="//static.somethingawful.com/css/main.css" rel="stylesheet" type="text/css">
<link href="https://fonts.googleapis.com/css?family=Roboto" rel="stylesheet">
<!--[if lt IE 8]>
      <link rel="stylesheet" type="text/css" href="//static.somethingawful.com/css/ie.css">
      <![endif]--><script src="//ajax.googleapis.com/ajax/libs/jquery/2.2.2/jquery.min.js" type="text/javascript"><script type="text/javascript" src="https://cdnjs.cloudflare.com/ajax/libs/jquery-migrate/1.4.0/jquery-migrate.min.js"></script></script><script src="//static.somethingawful.com/js/site.min.js" type="text/javascript"></script><script id="twitter-wjs" src="//platform.twitter.com/widgets.js" type="text/javascript"></script><script id="facebook-jssdk" src="//connect.facebook.net/en_US/all.js#xfbml=1" type="text/javascript"></script><script src="//static.somethingawful.com/js/jwplayer/jwplayer.js" type="text/javascript"></script><script src="//static.somethingawful.com/js/article.min.js" type="text/javascript"></script>
</head>
<body class="sa article c_63 a_15188">
<script type="text/javascript">var _gaq = _gaq || [];_gaq.push(['_setAccount', 'UA-33089744-1']);_gaq.push(['_trackPageview']);(function() {var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);})();</script><div class="chuck"><div class="neck"><ul class="scalp"><li><a href="/">Something Awful</a></li><li><a href="https://forums.somethingawful.com/">Something Awful Forums</a></li></ul><div class="head"><a class="logo" href="/"><span>Something Awful</span></a> <iframe class="ad" data-unit="top" src="about:blank"></iframe></div></div></div><div class="sirloin"><div class="ribs"><div class="site-nav"><ul><li class="forums"><a href="https://forums.somethingawful.com/">Forums</a></li><li class="photoshop-phriday"><a href="/photoshop-phriday/"><span class="full">Photoshop Phriday</span><span class="short">Photoshop</span></a></li><li class="comedy-goldmine"><a href="/comedy-goldmine/"><span class="full">Comedy Goldmine</span><span class="short">Goldmine</span></a></li><li class="the-flash-tub"><a href="/flash-tub/"><span class="full">The Flash Tub</span><span class="short">Flash Tub</span></a></li><li class="wtf-dd"><a href="/dungeons-and-dragons/"><span class="full">WTF, D&amp;D?!?</span><span class="short">WTFDD</span></a></li><li class="front-page-articles"><a href="/news/"><span class="full">Front Page Articles</span><span class="short">Front Page</span></a></li><li class="the-everdraed-showcase"><a href="/everdraed-showcase/"><span class="full">The Everdraed Showcase</span><span class="short">Everdraed</span></a></li><li class="video-game-article"><a href="/video-game-article/"><span class="full">Video Game Article</span><span class="short">Video Game</span></a></li><li class="current-releases"><a href="/current-movie-reviews/">Current Releases</a></li><li class="directory"><div class="directory-button"><a href="/directory/">Directory</a><div class="directory"><div class="item"><h4>Media</h4><ul><li><a href="/d/photoshop-phriday/">Photoshop Phriday</a></li><li><a href="/d/flash-tub/">The Flash Tub</a></li><li><a href="/d/comedy-goldmine/">Comedy Goldmine</a></li><li><a href="http://www.centralarc.com">Central ARC</a></li><li><a href="http://www.awfulvideo.com">Awful Video</a></li><li><a href="/d/cliff-yablonski/">Cliff Yablonski</a></li><li><a href="/booklist/index.htm">My Tank is Fight</a></li><li><a href="/d/directory.php#media">More</a></li></ul></div><div class="item"><h4>Articles</h4><ul><li><a href="/d/awful-movie-database/">Awful Movie Database</a></li><li><a href="/d/second-life-safari/">Secondlife Safari</a></li><li><a href="/d/weekend-web/">Weekend Web</a></li><li><a href="/d/pregame-wrapup/">Pregame Wrapup</a></li><li><a href="/d/icq-pranks/">Pranks (ICQ)</a></li><li><a href="/d/email-pranks/">Pranks (E-mail)</a></li><li><a href="/d/video-game-article/">Video Game Article</a></li><li><a href="/d/directory.php#articles">More</a></li></ul></div><div class="item"><h4>Reviews</h4><ul><li><a href="/d/your-band-sucks/">Your Band Sucks</a></li><li><a href="/d/movie-reviews/">Movie Reviews</a></li><li><a href="/d/hentai-game-reviews/">Awful Anime</a></li><li><a href="/d/rom-pit/">ROM Pit</a></li><li><a href="/d/fashion-swat/">Fashion SWAT</a></li><li><a href="/d/guides/">Guides</a></li><li><a href="/d/game-reviews/">Game Reviews</a></li><li><a href="/d/directory.php#reviews">More</a></li></ul></div><div class="item"><h4>Hosted</h4><ul><li><a href="/hosted/86">#86/68</a></li><li><a href="/hosted/adventures">Daring Armstrong</a></li><li><a href="/hosted/automaticturban">Semi-Automatic Turban</a></li><li><a href="/hosted/cliff">Cliff Yablonski</a></li><li><a href="/hosted/crabs">Leonard Crabs</a></li><li><a href="/hosted/cranky">Cranky Steve</a></li><li><a href="/hosted/drdraw">Dr Draw</a></li><li><a href="/hosted/edbaker">Ed Baker</a></li><li><a href="/hosted/firemancomics">Fireman Comics</a></li><li><a href="/hosted/jeffk">JEFF K</a></li></ul></div><div class="item"><h4>Forums</h4><ul><li><a href="https://forums.somethingawful.com/forumdisplay.php?forumid=1">General Discussion</a></li><li><a href="https://forums.somethingawful.com/forumdisplay.php?forumid=44">Video Games</a></li><li><a href="https://forums.somethingawful.com/forumdisplay.php?forumid=22">Hardware &amp; Software</a></li><li><a href="https://forums.somethingawful.com/forumdisplay.php?forumid=122">Sports</a></li><li><a href="https://forums.somethingawful.com/forumdisplay.php?forumid=133">Movie Reviews</a></li><li><a href="https://forums.somethingawful.com/forumdisplay.php?forumid=150">Music</a></li><li><a href="https://forums.somethingawful.com/forumdisplay.php?forumid=130">TV</a></li><li><a href="https://forums.somethingawful.com/">More</a></li></ul></div></div></div></li></ul></div><div class="brisket"><div class="cavity full top"><div class="organ breadcrumbs"> <a href="/directory/#articles">Articles</a> &gt; <a href="/news/">Front Page News</a></div></div><div class="cavity left"><div class="organ article_meta"><div class="article_head"><h1><a href="/news/alien-rpg-dungeon/">That New Alien Tabletop RPG Seems Familiar</a></h1> <span class="date">Tuesday, May 28, 2019</span> by <span class="authors"><span class="author"><a href="/author/21/">Dennis &#34;Corin Tucker&#39;s Stalker&#34; Farrell</a> (<a href="https://twitter.com/DennisFarrell" target="_blank">@DennisFarrell</a>)</span></span> </div><div class="social"><div class="twitter_tweet"><a class="twitter-share-button" data-counturl="http://www.somethingawful.com/news/alien-rpg-dungeon/" data-hashtags="somethingawful" data-related="DennisFarrell" data-text="That New Alien Tabletop RPG Seems Familiar" data-url="http://www.somethingawful.com/news/alien-rpg-dungeon/" data-via="somethingawful" href="https://twitter.com/share"></a></div><div class="facebook_like"><div class="fb-like" data-font="arial" data-href="http://www.somethingawful.com/news/alien-rpg-dungeon/" data-layout="button_count" data-send="false" data-show-faces="false" data-width="100"></div></div></div></div><div class="organ article"><p>After spending a few days with an early version of the <a href="https://alien-rpg.com/" target="_blank">Alien tabletop RPG</a>, I can't shake the feeling that something odd is going on. Am I being too nitpicky? You tell me.</p><p>Here's a scan from the class selection chapter. Pretty straightforward stuff.</p><p><img alt="" class="center imgcap" src="https://i.somethingawful.com/u/ctstalker/2019/alienrpgchar.jpg" width="500" /></p><p>My favorite entry in the monster manual section is also a little... off.</p><p><img alt="" class="center imgcap" src="https://i.somethingawful.com/u/ctstalker/2019/alienrpgmonster.jpg" width="500" /></p><p>Even the introductory quest seems a bit odd, though I can't quite put a finger on the reason.</p><p><img alt="" class="center imgcap" src="https://i.somethingawful.com/u/ctstalker/2019/alienrpgadventure.jpg" width="500" /></p><p>Oh heck, I'm probably just imagining things. The game is certainly fun. I suppose that's all that matters. Keep an eye out for this box later this year:</p><p><img alt="" class="center imgcap" src="https://i.somethingawful.com/u/ctstalker/2019/alienrpgredbox.jpg" width="500" /></p><div class="pb"></div><p class="signoff">–&nbsp;<span class="author"><a href="/author/21/">Dennis &#34;Corin Tucker&#39;s Stalker&#34; Farrell</a> (<a href="https://twitter.com/DennisFarrell" target="_blank">@DennisFarrell</a>)</span></p></div><div class="organ article_nav"> <a class="previous" href="/news/chernobyl-cbd-oil/" title="Could Chernobyl Have Been Prevented With CBD Oil?">Previous</a> <a class="more" href="/news/">More Front Page News</a> </div><div class="organ recent_articles"><h4>This Week on Something Awful...</h4><ul class="news"><li><div class="a_info"> <a class="image normal" href="/news/alien-rpg-dungeon/"> <img alt="That New Alien Tabletop RPG Seems Familiar" class="normal" src="https://i.somethingawful.com/sasbi/promo/8a20d7c7/b4ca634d/08739cf6/14e6063c/15188.jpg"> </a> <div class="info"><h3><a href="/news/alien-rpg-dungeon/">That New Alien Tabletop RPG Seems Familiar</a> </h3><div class="byline"><span class="date">05-28-2019</span> by <span class="authors"><span class="author"><a href="/author/21/">Dennis &#34;Corin Tucker&#39;s Stalker&#34; Farrell</a></span></span> </div><p>Holding high a gnarled staff wreath with holly, an elf summons the fury of the storm and calls down explosive bolts of lightning to smite the torch-carrying ALIENS who threaten her forest.</p></div><div class="pb"></div></div></li><li><div class="a_info"> <a class="image normal" href="/news/chernobyl-cbd-oil/"> <img alt="Could Chernobyl Have Been Prevented With CBD Oil?" class="normal" src="https://i.somethingawful.com/sasbi/promo/95693687/9f66f5cf/4ffbf3ae/fffd56ca/15187.jpg"> </a> <div class="info"><h3><a href="/news/chernobyl-cbd-oil/">Could Chernobyl Have Been Prevented With CBD Oil?</a> </h3><div class="byline"><span class="date">05-24-2019</span> by <span class="authors"><span class="author"><a href="/author/12/">Zack &#34;Geist Editor&#34; Parsons</a></span></span> </div><p>The disaster at the Chernobyl Nuclear Power Plant might have been mitigated if CBD oil had been given to the Soviet heroes. </p></div><div class="pb"></div></div></li></ul><ul class="featured"><li><div class="a_info"> <a class="image small" href="/photoshop-phriday/fucked-your-wife/"> <img alt="Y?WIFYW!" class="small" src="https://i.somethingawful.com/sasbi/promo/5b3b3e57/3becfa5d/7fac4916/f8bc0fed/15186t.jpg"> </a> <div class="info"><h3><a href="/photoshop-phriday/fucked-your-wife/">Y?WIFYW!</a> </h3><div class="c_name"> <a href="/photoshop-phriday/">Photoshop Phriday</a> </div><p>You think goons are sexist? Yeah!? Well...</p></div><div class="pb"></div></div></li><li><div class="a_info"> <a class="image small" href="/video-game-article/grocery-item-list/"> <img alt="The Video Game Item Grocery List" class="small" src="https://i.somethingawful.com/sasbi/promo/cd14d7ea/c0e4638d/ca6ef495/702dd013/15183t.jpg"> </a> <div class="info"><h3><a href="/video-game-article/grocery-item-list/">The Video Game Item Grocery List</a> </h3><div class="c_name"> <a href="/video-game-article/">Video Game Article</a> </div><p>Milk, eggs, augmentation upgrade canister</p></div><div class="pb"></div></div></li><li><div class="a_info"> <a class="image small" href="/video-game-article/sonic-trailer-valve/"> <img alt="Sonic Movie Trailer, Valve&#39;s $1000 VR, One Sentence Reviews" class="small" src="https://i.somethingawful.com/sasbi/promo/46c5976b/94ffe338/9fe63bed/55f9cc8f/15177t.jpg"> </a> <div class="info"><h3><a href="/video-game-article/sonic-trailer-valve/">Sonic Movie Trailer, Valve's $1000 VR, One Sentence Reviews</a> </h3><div class="c_name"> <a href="/video-game-article/">Video Game Article</a> </div><p>Sonic is too dang toothy, VR is too dang pricey, and Euro board games are just right</p></div><div class="pb"></div></div></li></ul></div><div class="pb"></div></div><div class="cavity right"><div class="organ adrect"><iframe class="ad" data-unit="right" src="about:blank"></iframe></div><div class="organ "><h3>About This Column</h3><div class="lining"><p>The Something Awful front page news tackles anything both off and on the Internet. Mostly "on" though, as we're all incredible nerds.</p><h4>Previous Articles</h4><ul class="previous_articles"><li><a href="/news/chernobyl-cbd-oil/">Could Chernobyl Have Been Prevented With CBD Oil?</a></li><li><a href="/news/favorite-scenes-thing/">My Favorite Scenes From The Thing, Good Will Hunting, and Jaws</a></li><li><a href="/news/game-thrones-remake/">PETITION: We Demand HBO Remake the Final Season of Game of Thrones and Rewrite Daenerys as Our Girlfriend</a></li><li><a href="/news/die-read-immortal/">20 Things You Simply MUST Do Before You Die</a></li><li><a href="/news/jeep-things-mother/">Jeep Things You Wouldn't Understand</a></li></ul><div class="more"><a href="/news/">More</a></div><h4>Suggested Articles</h4><ul class="suggested_articles"><li><a href="/dungeons-and-dragons/battletech-mechwarrior-magazine/1/">The Questionable Art of BattleTechnology Magazine</a></li><li><a href="/dungeons-and-dragons/cthulhu-keeper-tool/">The Lollapaloozicon Random 1990s Cthulhu Adventure Generator</a></li><li><a href="/movie-reviews/curse-kingtut-part1/1/">The Curse of King Tut's Tomb, Part 1</a></li><li><a href="/current-movie-reviews/easy-devil-town/1/">Easy A; Devil; The Town</a></li><li><a href="/movie-reviews/shadow-men/">The Shadow Men</a></li></ul></div></div><div class="organ whatshot"><h3>What&#39;s Hot</h3><div class="lining"><ul class="whatshot"><li><a href="/comedy-goldmine/twisted-childrens-books/1/">Twisted Children's Books</a></li><li><a href="/photoshop-phriday/stupid-products-for/1/">Stupid Products for Stupid People</a></li><li><a href="/news/dynamars-kiosk2/1/">Welcome to the DynaMars Corporation Cycnus Station Update Kiosk</a></li><li><a href="/dungeons-and-dragons/fatal-worst-rpg/1/">The 10 Reasons We Will Never Review F.A.T.A.L.</a></li><li><a href="/current-movie-reviews/thor-fast-five/1/">Thor; Fast Five; Super; Prom; Jane Eyre; Win Win</a></li></ul></div></div><div class="organ popular_threads"><h3>Popular Threads</h3><div class="lining"><ul class="random"><li><img alt="" height="15" src="https://fi.somethingawful.com/forums/posticons/sports-nhl.gif" width="60"> <a href="https://forums.somethingawful.com/showthread.php?threadid=3890604" title="NHL GDT - Blues at Bruins Stanley Cup Finals Game 1">NHL GDT - Blues at Bruins Stanley Cup Finals Game 1</a></li><li><img alt="" height="15" src="https://fi.somethingawful.com/forums/posticons/games-coop.gif" width="60"> <a href="https://forums.somethingawful.com/showthread.php?threadid=3890621" title="CEORFATH">CEORFATH</a></li><li><img alt="" height="15" src="https://fi.somethingawful.com/forums/posticons/LF-japan_clean_fast.gif" width="60"> <a href="https://forums.somethingawful.com/showthread.php?threadid=3890599" title="Nioh 2">Nioh 2</a></li><li><img alt="" height="15" src="https://fi.somethingawful.com/forums/posticons/sports-wwe.gif" width="60"> <a href="https://forums.somethingawful.com/showthread.php?threadid=3890611" title="WWE Discussion Has a Year To Cash-in? Well Screw You Then! for 5/27">WWE Discussion Has a Year To Cash-in? Well Screw You Then! for 5/27</a></li><li><img alt="" height="15" src="https://fi.somethingawful.com/forums/posticons/sports-mlb.gif" width="60"> <a href="https://forums.somethingawful.com/showthread.php?threadid=3890581" title="MLB Week 9 GDT: Remember, there is always day ball on Memorial Day">MLB Week 9 GDT: Remember, there is always day ball on Memorial Day</a></li><li><img alt="" height="15" src="https://fi.somethingawful.com/forums/posticons/lf-putin.png" width="60"> <a href="https://forums.somethingawful.com/showthread.php?threadid=3890606" title="Can we please keep election interference out of cspam">Can we please keep election interference out of cspam</a></li><li><img alt="" height="15" src="https://fi.somethingawful.com/forums/posticons/games-rng.gif" width="60"> <a href="https://forums.somethingawful.com/showthread.php?threadid=3890597" title="[BattleTech] Who do you think you are, the Wolf's Dragoons?">[BattleTech] Who do you think you are, the Wolf's Dragoons?</a></li><li><img alt="" height="15" src="https://fi.somethingawful.com/forums/posticons/byob-xfile.gif" width="60"> <a href="https://forums.somethingawful.com/showthread.php?threadid=3890596" title="Apollo 11">Apollo 11</a></li></ul></div></div><div class="organ random_articles"><h3>Random Articles</h3><div class="lining"><ul class="random"><li><a href="/news/god-plan-heist/">God's Plan</a></li><li><a href="/news/roamin-dad-22/">Subj: YOUR SISTER IS GETTING MARRIED TO &quot;GREG&quot;</a></li><li><a href="/awful-links/awful-link-3146/">OneBucPlace</a></li><li><a href="/news/exotic-shotgun-911/">Choosing the Right Exotic Shotgun Shell for Your 9/11 Party</a></li><li><a href="/news/pomplamoose-last-christmas/">The Anti-Christmas: A Yule-dimmed Tide</a></li></ul><div class="more"><a href="/random/" rel="nofollow">Random!</a></div></div></div><div class="organ side_search"><h3>Search</h3><div class="lining"><form action="/search/" class="site" method="get"><div class="iwrapper"><input name="q" placeholder="Search SA" type="text" /></div><button class="ui small">GO</button> <input name="t" type="hidden" value="0" /> <input name="c" type="hidden" value="0" /> <input name="a" type="hidden" value="0" /> <input name="y" type="hidden" value="0" /> <input name="p" type="hidden" value="1" /></form><form action="/search/amazon/" class="amazon" method="post" target="_blank"><div class="iwrapper"><input name="q" placeholder="Search Amazon" type="text" /></div><button class="ui small">GO</button></form><div class="links"><a class="email" href="mailto:webmaster@somethingawful.com">Email Rich "Lowtax" Kyanka</a> <a class="advertise" href="/feature-articles/something-awful-advertising/">Advertise on SA</a></div></div></div><div class="pb"></div></div><div class="cavity full bottom"><div class="organ ad leaderboard"><iframe class="ad" data-unit="bottom" src="about:blank"></iframe></div></div></div></div></div><div class="rump"><div class="leg"><div class="hoof"><p><strong>Copyright ©2019</strong> Rich "Lowtax" Kyanka &amp; Something Awful LLC.</p><ul><li><a href="mailto:lowtax@somethingawful.com">Email Rich "Lowtax" Kyanka</a></li><li><a href="mailto:advertising@somethingawful.com">Advertise on this site</a></li><li><a href="/feature-articles/website-privacy-policy/">Privacy Statement</a></li><li><a href="/alod/new/">Submit Awful Link</a></li></ul></div></div></div>
</body>
</html>