<!DOCTYPE html>
<html>
<head>
<meta charset="utf-8">
<meta content="width=device-width, initial-scale=1.0, maximum-scale=1.0, user-scalable=no" name="viewport">
<meta content="noodp" name="robots">
<script src="/cdn-cgi/apps/head/HUrzTLAxQgicYEiE3OhKRjNWSOg.js"></script><link href="/rss/frontpage.xml" rel="alternate" title="Latest Articles" type="application/rss+xml">
<link href="/rss/news.xml" rel="alternate" title="Front Page News" type="application/rss+xml"><meta content="summary" name="twitter:card"><meta content="http://www.somethingawful.com/a/15229/" name="twitter:url"><meta content="For My Money, I Spit On Your Grave 23 Is Where The Franchise Began To Lose Steam" name="twitter:title"><meta content="I Spit On Your Grave 14: I&#39;m On A Seagrave Diet... When I See Your Grave I Spit On It!" name="twitter:description"><meta content="http://i.somethingawful.com/sasbi/promo/bbdba257/f96ea1bf/a6e0aa82/9c59984c/15229newsimg.jpg" name="twitter:image"><meta content="@somethingawful" name="twitter:site"><meta content="@DennisFarrell" name="twitter:creator"><meta content="article" property="og:type"><meta content="Something Awful - For My Money, I Spit On Your Grave 23 Is Where The Franchise Began To Lose Steam" property="og:title"><meta content="http://www.somethingawful.com/news/spit-grave-sequels/" property="og:url"><meta content="http://i.somethingawful.com/sasbi/promo/bbdba257/f96ea1bf/a6e0aa82/9c59984c/15229newsimg.jpg" property="og:image"><meta content="somethingawful.com" property="og:site_name"><meta content="I Spit On Your Grave 14: I&#39;m On A Seagrave Diet... When I See Your Grave I Spit On It!" property="og:description"><meta content="2019-09-25T00:00:00+00:00" property="og:updated_time">
<title>For My Money, I Spit On Your Grave 23 Is Where The Franchise Began To Lose Steam</title>
<link href="//static.somethingawful.com/css/main.css" rel="stylesheet" type="text/css">
<link href="https://fonts.googleapis.com/css?family=Roboto" rel="stylesheet">
<!--[if lt IE 8]>
      <link rel="stylesheet" type="text/css" href="//static.somethingawful.com/css/ie.css">
      <![endif]--><script src="//ajax.googleapis.com/ajax/libs/jquery/2.2.2/jquery.min.js" type="text/javascript"><script type="text/javascript" src="https://cdnjs.cloudflare.com/ajax/libs/jquery-migrate/1.4.0/jquery-migrate.min.js"></script></script><script src="//static.somethingawful.com/js/site.min.js" type="text/javascript"></script><script id="twitter-wjs" src="//platform.twitter.com/widgets.js" type="text/javascript"></script><script id="facebook-jssdk" src="//connect.facebook.net/en_US/all.js#xfbml=1" type="text/javascript"></script><script src="//static.somethingawful.com/js/jwplayer/jwplayer.js" type="text/javascript"></script><script src="//static.somethingawful.com/js/article.min.js" type="text/javascript"></script>
</head>
<body class="sa article c_63 a_15229">
<script type="text/javascript">var _gaq = _gaq || [];_gaq.push(['_setAccount', 'UA-33089744-1']);_gaq.push(['_trackPageview']);(function() {var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);})();</script><div class="chuck"><div class="neck"><ul class="scalp"><li><a href="/">Something Awful</a></li><li><a href="https://forums.somethingawful.com/">Something Awful Forums</a></li></ul><div class="head"><a class="logo" href="/"><span>Something Awful</span></a> <iframe class="ad" data-unit="top" src="about:blank"></iframe></div></div></div><div class="sirloin"><div class="ribs"><div class="site-nav"><ul><li class="forums"><a href="https://forums.somethingawful.com/">Forums</a></li><li class="photoshop-phriday"><a href="/photoshop-phriday/"><span class="full">Photoshop Phriday</span><span class="short">Photoshop</span></a></li><li class="comedy-goldmine"><a href="/comedy-goldmine/"><span class="full">Comedy Goldmine</span><span class="short">Goldmine</span></a></li><li class="the-flash-tub"><a href="/flash-tub/"><span class="full">The Flash Tub</span><span class="short">Flash Tub</span></a></li><li class="wtf-dd"><a href="/dungeons-and-dragons/"><span class="full">WTF, D&amp;D?!?</span><span class="short">WTFDD</span></a></li><li class="front-page-articles"><a href="/news/"><span class="full">Front Page Articles</span><span class="short">Front Page</span></a></li><li class="the-everdraed-showcase"><a href="/everdraed-showcase/"><span class="full">The Everdraed Showcase</span><span class="short">Everdraed</span></a></li><li class="video-game-article"><a href="/video-game-article/"><span class="full">Video Game Article</span><span class="short">Video Game</span></a></li><li class="current-releases"><a href="/current-movie-reviews/">Current Releases</a></li><li class="directory"><div class="directory-button"><a href="/directory/">Directory</a><div class="directory"><div class="item"><h4>Media</h4><ul><li><a href="/d/photoshop-phriday/">Photoshop Phriday</a></li><li><a href="/d/flash-tub/">The Flash Tub</a></li><li><a href="/d/comedy-goldmine/">Comedy Goldmine</a></li><li><a href="http://www.centralarc.com">Central ARC</a></li><li><a href="http://www.awfulvideo.com">Awful Video</a></li><li><a href="/d/cliff-yablonski/">Cliff Yablonski</a></li><li><a href="/booklist/index.htm">My Tank is Fight</a></li><li><a href="/d/directory.php#media">More</a></li></ul></div><div class="item"><h4>Articles</h4><ul><li><a href="/d/awful-movie-database/">Awful Movie Database</a></li><li><a href="/d/second-life-safari/">Secondlife Safari</a></li><li><a href="/d/weekend-web/">Weekend Web</a></li><li><a href="/d/pregame-wrapup/">Pregame Wrapup</a></li><li><a href="/d/icq-pranks/">Pranks (ICQ)</a></li><li><a href="/d/email-pranks/">Pranks (E-mail)</a></li><li><a href="/d/video-game-article/">Video Game Article</a></li><li><a href="/d/directory.php#articles">More</a></li></ul></div><div class="item"><h4>Reviews</h4><ul><li><a href="/d/your-band-sucks/">Your Band Sucks</a></li><li><a href="/d/movie-reviews/">Movie Reviews</a></li><li><a href="/d/hentai-game-reviews/">Awful Anime</a></li><li><a href="/d/rom-pit/">ROM Pit</a></li><li><a href="/d/fashion-swat/">Fashion SWAT</a></li><li><a href="/d/guides/">Guides</a></li><li><a href="/d/game-reviews/">Game Reviews</a></li><li><a href="/d/directory.php#reviews">More</a></li></ul></div><div class="item"><h4>Hosted</h4><ul><li><a href="/hosted/86">#86/68</a></li><li><a href="/hosted/adventures">Daring Armstrong</a></li><li><a href="/hosted/automaticturban">Semi-Automatic Turban</a></li><li><a href="/hosted/cliff">Cliff Yablonski</a></li><li><a href="/hosted/crabs">Leonard Crabs</a></li><li><a href="/hosted/cranky">Cranky Steve</a></li><li><a href="/hosted/drdraw">Dr Draw</a></li><li><a href="/hosted/edbaker">Ed Baker</a></li><li><a href="/hosted/firemancomics">Fireman Comics</a></li><li><a href="/hosted/jeffk">JEFF K</a></li></ul></div><div class="item"><h4>Forums</h4><ul><li><a href="https://forums.somethingawful.com/forumdisplay.php?forumid=1">General Discussion</a></li><li><a href="https://forums.somethingawful.com/forumdisplay.php?forumid=44">Video Games</a></li><li><a href="https://forums.somethingawful.com/forumdisplay.php?forumid=22">Hardware &amp; Software</a></li><li><a href="https://forums.somethingawful.com/forumdisplay.php?forumid=122">Sports</a></li><li><a href="https://forums.somethingawful.com/forumdisplay.php?forumid=133">Movie Reviews</a></li><li><a href="https://forums.somethingawful.com/forumdisplay.php?forumid=150">Music</a></li><li><a href="https://forums.somethingawful.com/forumdisplay.php?forumid=130">TV</a></li><li><a href="https://forums.somethingawful.com/">More</a></li></ul></div></div></div></li></ul></div><div class="brisket"><div class="cavity full top"><div class="organ breadcrumbs"> <a href="/directory/#articles">Articles</a> &gt; <a href="/news/">Front Page News</a></div></div><div class="cavity left"><div class="organ article_meta"><div class="article_head"><h1><a href="/news/spit-grave-sequels/">For My Money, I Spit On Your Grave 23 Is Where The Franchise Began To Lose Steam</a></h1> <span class="date">Wednesday, Sep 25, 2019</span> by <span class="authors"><span class="author"><a href="/author/21/">Dennis &#34;Corin Tucker&#39;s Stalker&#34; Farrell</a> (<a href="https://twitter.com/DennisFarrell" target="_blank">@DennisFarrell</a>)</span></span> </div><div class="social"><div class="twitter_tweet"><a class="twitter-share-button" data-counturl="http://www.somethingawful.com/news/spit-grave-sequels/" data-hashtags="somethingawful" data-related="DennisFarrell" data-text="For My Money, I Spit On Your Grave 23 Is Where The Franchise Began To Lose Steam" data-url="http://www.somethingawful.com/news/spit-grave-sequels/" data-via="somethingawful" href="https://twitter.com/share"></a></div><div class="facebook_like"><div class="fb-like" data-font="arial" data-href="http://www.somethingawful.com/news/spit-grave-sequels/" data-layout="button_count" data-send="false" data-show-faces="false" data-width="100"></div></div></div></div><div class="organ article"><p><span class="font_big">I Spit On Your Grave 4: Still Spittin'<p>I Spit On Your Grave 5: Had To Attend A Family Event So I Didn't Get To Swing By And Spit On Your Grave This Year But I'll Try To Work A Second Spit Into My Schedule Next Year</p><p><img alt="" class="right imgcap" src="https://i.somethingawful.com/u/ctstalker/2019/ispit.jpg" width="280" />I Spit On Your Grave 6: When You Kaput But I Keep Spitting</p><p>I Spit On Your Grave 7: A Mouthful Of Loogies</p><p>I Spit On Your Grave 8: A Few Loogies More</p><p>I Spit On Your Grave 9: The Spit Is Coming From Inside The Grave</p><p>I Spit On Your Grave X: Spitting In Space</p><p>I Spit On Your Grave 11: Simply Spit On The Grave, Then Ship The Grave To Our Lab To Discover Your Ancestry</p><p>I Spit On Your Grave 12: Wrong Grave. All These Years. Fuck!</p><p>I Spit On Your Grave 13: Spit Happens</p><p>I Spit On Your Grave 14: I'm On A Seagrave Diet... When I See Your Grave I Spit On It!</p><p>I Spit On Your Grave 15: Another Phlegm Hits The Dust</p><p>I Spit On Your Grave 16: Dig Two Graves - One For You And One For My Spit</p><p>I Spat On Your Grave (Set in the far future)</p><p>I Will Spit On Your Grave (Prequel, set before the events of I Spit On Your Grave 1)</p><p>I Spit On Your Grave 19: The Gravekeeper Sighs As I Walk Through The Gate And I Shrug Apologetically</p><p>An I Spit On Your Grave Wedding: With This Spit, I Thee Grave</p><p>I Spit On Your Grave 21: Look Who's Spitting</p><p>I Spit On Your Grave 22: No Grave For Old Spit</p><p>The I Spit On Your Grave Christmas Movie: Silent Grave, Holy Spit</p><p>I Spit On Your Grave: The Final Chapter...</p><p>I Spit On Your Grave 25: ...Has Yet To Be Spitten</p></span></p><div class="pb"></div><p class="signoff">–&nbsp;<span class="author"><a href="/author/21/">Dennis &#34;Corin Tucker&#39;s Stalker&#34; Farrell</a> (<a href="https://twitter.com/DennisFarrell" target="_blank">@DennisFarrell</a>)</span></p></div><div class="organ article_nav"> <a class="previous" href="/news/spider-costume-outfit/" title="We Can All Agree This Is Spider-Man's Best Costume">Previous</a> <a class="more" href="/news/">More Front Page News</a> </div><div class="organ recent_articles"><h4>This Week on Something Awful...</h4><ul class="news"><li><div class="a_info"> <a class="image normal" href="/news/spit-grave-sequels/"> <img alt="For My Money, I Spit On Your Grave 23 Is Where The Franchise Began To Lose Steam" class="normal" src="https://i.somethingawful.com/sasbi/promo/bbdba257/f96ea1bf/a6e0aa82/9c59984c/15229.jpg"> </a> <div class="info"><h3><a href="/news/spit-grave-sequels/">For My Money, I Spit On Your Grave 23 Is Where The Franchise Began To Lose Steam</a> </h3><div class="byline"><span class="date">09-25-2019</span> by <span class="authors"><span class="author"><a href="/author/21/">Dennis &#34;Corin Tucker&#39;s Stalker&#34; Farrell</a></span></span> </div><p>I Spit On Your Grave 14: I&#39;m On A Seagrave Diet... When I See Your Grave I Spit On It!</p></div><div class="pb"></div></div></li><li><div class="a_info"> <a class="image normal" href="/news/spider-costume-outfit/"> <img alt="We Can All Agree This Is Spider-Man&#39;s Best Costume" class="normal" src="https://i.somethingawful.com/sasbi/promo/16db016e/d3a5b8d7/c5969283/06161ada/15227.png"> </a> <div class="info"><h3><a href="/news/spider-costume-outfit/">We Can All Agree This Is Spider-Man's Best Costume</a> </h3><div class="byline"><span class="date">09-17-2019</span> by <span class="authors"><span class="author"><a href="/author/21/">Dennis &#34;Corin Tucker&#39;s Stalker&#34; Farrell</a></span></span> </div><p>&#34;Whatever.&#34; The word that defined a generation. The rallying cry of Generation X. The mantra of Generation Surge. Peter Parker said it first, while wearing his best costume.</p></div><div class="pb"></div></div></li></ul><ul class="featured"><li><div class="a_info"> <a class="image small" href="/video-game-article/borderlands-weapon-reviews/"> <img alt="You NEED These Weapons to Fully Enjoy Borderlands 3" class="small" src="https://i.somethingawful.com/sasbi/promo/428365de/6e004c61/5fe51282/a0b8d9db/15228t.jpg"> </a> <div class="info"><h3><a href="/video-game-article/borderlands-weapon-reviews/">You NEED These Weapons to Fully Enjoy Borderlands 3</a> </h3><div class="c_name"> <a href="/video-game-article/">Video Game Article</a> </div><p>Borderlands 3 and the latest batch of One Sentence Reviews!</p></div><div class="pb"></div></div></li><li><div class="a_info"> <a class="image small" href="/photoshop-phriday/trump-wood-statue/"> <img alt="The President Has Wood(en Statue)" class="small" src="https://i.somethingawful.com/sasbi/promo/ebae5f81/d1c4563a/e8f8d07b/9290324f/15224t.jpg"> </a> <div class="info"><h3><a href="/photoshop-phriday/trump-wood-statue/">The President Has Wood(en Statue)</a> </h3><div class="c_name"> <a href="/photoshop-phriday/">Photoshop Phriday</a> </div><p>Are you ready for more Trump jokes? No wait come back! We also mock crude wooden figures!!!</p></div><div class="pb"></div></div></li><li><div class="a_info"> <a class="image small" href="/video-game-article/dreamcast-gdemu-ossc/"> <img alt="Old Games On New TVs: The Sega Dreamcast" class="small" src="https://i.somethingawful.com/sasbi/promo/57b33ae6/c0bf00c4/54900bea/31d88893/15221t.jpg"> </a> <div class="info"><h3><a href="/video-game-article/dreamcast-gdemu-ossc/">Old Games On New TVs: The Sega Dreamcast</a> </h3><div class="c_name"> <a href="/video-game-article/">Video Game Article</a> </div><p>Celebrating the Dreamcast&#39;s 20th anniversary by gutting one and painting it badly</p></div><div class="pb"></div></div></li></ul></div><div class="pb"></div></div><div class="cavity right"><div class="organ adrect"><iframe class="ad" data-unit="right" src="about:blank"></iframe></div><div class="organ "><h3>About This Column</h3><div class="lining"><p>The Something Awful front page news tackles anything both off and on the Internet. Mostly "on" though, as we're all incredible nerds.</p><h4>Previous Articles</h4><ul class="previous_articles"><li><a href="/news/spider-costume-outfit/">We Can All Agree This Is Spider-Man's Best Costume</a></li><li><a href="/news/johnston-palin-divorce/">I AM PREPARED TO OFFER MY HUSBANDLY DUTIES TO MRS. PALIN</a></li><li><a href="/news/pilot-plane-anyone/">Folks, This Is Your Pilot Speaking</a></li><li><a href="/news/jack-ryan-sucks/">The premises for all seven seasons of Jack Ryan on Amazon</a></li><li><a href="/news/renner-app-patch/">Patch Notes: The Jeremy Renner App</a></li></ul><div class="more"><a href="/news/">More</a></div><h4>Suggested Articles</h4><ul class="suggested_articles"><li><a href="/comedy-goldmine/fantasy-book-covers/1/">Terrible Fantasy/Sci-Fi Book Art!</a></li><li><a href="/news/trans-bathroom-seagal/">Only Steven Seagal Can Protect Our Children in the Bathroom</a></li><li><a href="/comedy-goldmine/post-apocalyptic-seinfeld/1/">Fallout: Seinfeld!</a></li><li><a href="/current-movie-reviews/insidious-chapter2/1/">Insidious: Chapter 2; The Family; I Spit on Your Grave 2; The Grandmaster</a></li><li><a href="/news/dostoevsky-ip-riaa/">Dostoevsky's Copyright Crime &amp; Punishment</a></li></ul></div></div><div class="organ whatshot"><h3>What&#39;s Hot</h3><div class="lining"><ul class="whatshot"><li><a href="/photoshop-phriday/variety-pack-12/1/">Variety Pack #12: Movie Premakes and Rejected Indiana Jones Films!</a></li><li><a href="/great-goon-database/great-goon-work/1/">World of Workraft</a></li><li><a href="/photoshop-phriday/before-after-movies/1/">Before and After Movies</a></li><li><a href="/video-game-article/borderlands-weapon-reviews/">You NEED These Weapons to Fully Enjoy Borderlands 3</a></li><li><a href="/great-goon-database/great-goon-rage/1/">Nerd Rage!</a></li></ul></div></div><div class="organ popular_threads"><h3>Popular Threads</h3><div class="lining"><ul class="random"><li><img alt="" height="15" src="https://fi.somethingawful.com/forums/posticons/fyad-trout.gif" width="60"> <a href="https://forums.somethingawful.com/showthread.php?threadid=3899730" title="cat louvers">cat louvers</a></li><li><img alt="" height="15" src="https://fi.somethingawful.com/forums/posticons/bss-swag.gif" width="60"> <a href="https://forums.somethingawful.com/showthread.php?threadid=3899737" title="pour one out for mandrake linux">pour one out for mandrake linux</a></li><li><img alt="" height="15" src="https://fi.somethingawful.com/forums/posticons/byob-explosion.gif" width="60"> <a href="https://forums.somethingawful.com/showthread.php?threadid=3899724" title="Make up your own adventure: Let us make the worst choices">Make up your own adventure: Let us make the worst choices</a></li><li><img alt="" height="15" src="https://fi.somethingawful.com/forums/posticons/dd-9-11.gif" width="60"> <a href="https://forums.somethingawful.com/showthread.php?threadid=3899722" title="car louvers">car louvers</a></li><li><img alt="" height="15" src="https://fi.somethingawful.com/forums/posticons/icons-08/video.png" width="60"> <a href="https://forums.somethingawful.com/showthread.php?threadid=3899757" title="Games Done Quick Express 2019: Games Done Quick 3: Games Done Quickerer">Games Done Quick Express 2019: Games Done Quick 3: Games Done Quickerer</a></li><li><img alt="" height="15" src="https://fi.somethingawful.com/forums/posticons/cd_action.gif" width="60"> <a href="https://forums.somethingawful.com/showthread.php?threadid=3899694" title="Do you still get a rush of adrenaline when a car cuts you off">Do you still get a rush of adrenaline when a car cuts you off</a></li><li><img alt="" height="15" src="https://fi.somethingawful.com/forums/posticons/byob-slayer.gif" width="60"> <a href="https://forums.somethingawful.com/showthread.php?threadid=3899745" title="nfl week 4 aftermath: we watch people die while we eat chicken wings">nfl week 4 aftermath: we watch people die while we eat chicken wings</a></li><li><img alt="" height="15" src="https://fi.somethingawful.com/forums/posticons/icons-08/science.png" width="60"> <a href="https://forums.somethingawful.com/showthread.php?threadid=3899711" title="El Camino: A Breaking Bad Movie">El Camino: A Breaking Bad Movie</a></li></ul></div></div><div class="organ random_articles"><h3>Random Articles</h3><div class="lining"><ul class="random"><li><a href="/current-movie-reviews/twilight-eclipse/">The Twilight Saga: Eclipse</a></li><li><a href="/mooflogs/alito-wants-overturn/">Alito wants to overturn Marvel v Capcom</a></li><li><a href="/awful-links/awful-link-3394/">Ascension 2000</a></li><li><a href="/news/nude-positions-no/">Nude positions... no, not those kinds</a></li><li><a href="/photoshop-phriday/troll-dolls-beaks/1/">Trolls and Beaks</a></li></ul><div class="more"><a href="/random/" rel="nofollow">Random!</a></div></div></div><div class="organ side_search"><h3>Search</h3><div class="lining"><form action="/search/" class="site" method="get"><div class="iwrapper"><input name="q" placeholder="Search SA" type="text" /></div><button class="ui small">GO</button> <input name="t" type="hidden" value="0" /> <input name="c" type="hidden" value="0" /> <input name="a" type="hidden" value="0" /> <input name="y" type="hidden" value="0" /> <input name="p" type="hidden" value="1" /></form><form action="/search/amazon/" class="amazon" method="post" target="_blank"><div class="iwrapper"><input name="q" placeholder="Search Amazon" type="text" /></div><button class="ui small">GO</button></form><div class="links"><a class="email" href="mailto:webmaster@somethingawful.com">Email Rich "Lowtax" Kyanka</a> <a class="advertise" href="/feature-articles/something-awful-advertising/">Advertise on SA</a></div></div></div><div class="pb"></div></div><div class="cavity full bottom"><div class="organ ad leaderboard"><iframe class="ad" data-unit="bottom" src="about:blank"></iframe></div></div></div></div></div><div class="rump"><div class="leg"><div class="hoof"><p><strong>Copyright ©2019</strong> Rich "Lowtax" Kyanka &amp; Something Awful LLC.</p><ul><li><a href="mailto:lowtax@somethingawful.com">Email Rich "Lowtax" Kyanka</a></li><li><a href="mailto:advertising@somethingawful.com">Advertise on this site</a></li><li><a href="/feature-articles/website-privacy-policy/">Privacy Statement</a></li><li><a href="/alod/new/">Submit Awful Link</a></li></ul></div></div></div>
</body>
</html>